to render movies in MPEG-4 format using quicktime in blender, do you have to have quicktime pro?

Yeah, I think so. The export menu in QT, which lets you re-encode is only available in the Pro version. True, it’s only a serial code you need but I wouldn’t recommend that you look online for one :wink:

I haven’t actually tried to render straight to a Quicktime movie before. I normally render to an image sequence so that I can replace or edit frames if needs be and then load the sequence into Quicktime and save uncompressed (you can do this in the non-pro version). There are free encoders that you can use to produce various video formats from this uncompressed form.

ffmpegx does mpg-1, mpg-2, divx, xvid etc. I have used Apple’s mpeg-4 but it’s not the best encoder around. It is probably the best video format that most people can watch online. QT Pro’s only $30 anyway. Video games are way more expensive than that. I would recommend you get it because it is very functional (especially as you can use scripts with it too).

If you do it from Blender, I don’t think you need the pro version. Could be wrong though.


I think you’re right theeth. I thought that the price for the QT Pro version was the fee for distributing media in the formats that QT Pro provides but it must be for the editing features. There’s nothing in the developer documentation that says you need QT Pro for import/export from different applications.

Well, QuickTime Pro gives you more MPEG4 Export options from the QuickTime Player itself - rather than export a generic QuickTime file using MPEG4 as a video codec (as you do in Blender), there’s an additional ‘MPEG4 Video’ exporter with lots of codec/compression settings. I don’t know if the codec itself is different or not between pro/free - perhaps the Pro version could be higher quality.

As far as exporting from Blender though, I was under the impression you could export to MPEG4 with the free version - why not just try it and see if it works? :slight_smile:

actually, i tried it and it didnt work, so i was wondering if i was doing something wrong, or if its not even supposed to work.
(btw, you choose “quicktime” as the format and “mpeg-4” as the codec, rite?)