Quite a surprise (save warning)

ever since i am using blender, first time it shows to me. I captured it…:slight_smile: again i tried, but this time it closed without warning as usual…


In File -> User Preferences , at the Interface tab, enable “Prompt Quit”
Then in the bottom of that User Preferences window you can click on “Save User Settings” so “Prompt Quit” will be enable everytime you launch Blender

Sorry but working on mac here and in 2.69 it’s not there, just had a 2-3 hours session wasted :frowning:


You went three hours without saving?

Have you not tried opening the autosave file (assuming you enabled it in user preferences)

Yes that does work, but i find that prompt on quite usefull. As some of the shortcuts are close a accidental quit sometimes happens, also i do like the reminder… But there is no option in prefs for mac, does windows do have this option to turn it on and off?

It’s here on Windows and has been for long enough that I have found it irritating and have turned it off. Go figure, before we had it I fretted about not having it but now it’s just a pain to constantly tell it yes, I want to discard changes…

Your screenshot doesn’t show the option under the show splash so I wonder if something in the Mac window manager is blocking it. If you really want to go without saving try checking the keep session button and it should load the autosaved file when you startup.

But still i would have a ‘x’ min time interval if i have this option on. Sometimes stuff on a mac is different i noticed, making the window fullscreen was also in a different place. But this option is completely left away :frowning:

A quick look on google seems to hint that the Prompt only option is only found on windows releases ?

Apparently on Mac you can get a prompt only with a key shortcut combination :

About Macs:

Closing the app with Cmd Q invokes the save prompt. Quitting with Cmd W doesn’t. (possible bug?) The only indication that you haven’t saved is the ‘dot’ in the red, close-window button, top left of the window.

Weirdest thing here, i was diving into to the source code and see if i could find the key bindings or anything about the prompt quite popup. Suddenly it does popup, however still the option isnt in the prefs

Well cmd w does give me a prompt actually and the cmd q also… but i quite not understand why i didnt before. I cant seem to recreate this error… :frowning:

I never noticed that with the reddot and im a mac user since way long back, hahaha never to ‘old’ to learn. I find that recover last sessions quite usefull i think. Thanks!