QWER Addon - or how I stopped using the transform active tools

DCCs? …

Dutch Comic Con? No…
Day Chocolate Company? No…
Dynamic Combinatorial Chemistry? No…
Dallas Christian College? No…

Wait…

Digital Content Creation! :smiley: I’m going to use this too from now on. Sounds much more sophisticated than “3D app”. :wink:

“What DCCs do you use these days?”
“Well, uh… I’m not on medication currently.”
:grin:

1 Like

Come on! I mistook you for an old vet. You should know that one. :rofl:

1 Like

Maybe I’ve entered the post-vet dementia stage. :grin:

1 Like

OH…I thought we were talking about Dachshund Crisis Counseling. I realize now that what I’ve said about Blender has been completely unwarranted and that I’m in the wrong line of work.

1 Like

Given the versatility of Blender it wouldn’t surprise me if the next Blender Developers announcement will be support for Dachshund Crisis Counseling.

1 Like

Hi dpdp,
Thanks for your tool. I use it for a few days but I’ve a problem with the shortcut for the scale gizmo.
I’ve set the shortcut of all 3 gizmos with the right click menu but the scale gizmo always act as add scale Gizmo. The rotate and move work as expected. Here’s my shorcut setup:

image

Did the recent API changes break the addon slightly? Move toggles on by default when switching to scale/rotate (as if pressing add move). And when pressing move/scale (to remove the gizmo) the move one appears again.

edit: you can fix this manually in the keymaps, but assigning the shortcut through the panel assigns the wrong settings.

Thanks for catching that @TomSeas.

The problem is that the shift key makes the AddMove etc work using the buttons in the interface…if that makes sense. So the operator checks to see if the shift key is pressed to see if it needs to make the move, rotate or scale exclusive or if it needs to add to the existing transform gizmo. So it sort of short circuited the script when it saw the shift key was pressed. I modified the addon so you have the option to use the mode property instead of the toggle buttons for move rotate and scale. Now if you want to use a shift key in your keymap, you can uncheck all of the checkboxes and use the name of the transform in the “name” box: Move, Rotate, or Scale.

I’ll see if I can make a smarter way of handling keystrokes that use the shift modifier, but until then, you can download the latest build on github.

How to set it up

Thanks a lot.

1 Like

Thank a lot for this since i found blender make us work more and do more click for nothing and when you suffer from rsi in the past you know that the less clicking the better you will be and that time is money…

1 Like

Not sure for how long but there’s Industry Standard Keymap now which works very similar to Maya

hi dpdp
is QWER working in daily builds?

It turns out the addon that was on my github was broken. It’s fixed now, so try downloading it again if you had issues.

2 Likes

I’ve got an issue : how to disable the rotate and grab/transform in sculpt mode ?

There are several places to turn them on or off depending on what settings you have set for the addon. The viewport gizmos dropdown should be visible no matter what settings you have set, as long as the header isn’t hidden in the 3d View.
None of these locations should disappear when you switch to sculpt mode.

Depending on how you have your keymap set up, you may not be able to access the functionality through keymaps in sculpt mode. Keymap entries can either be mode dependent or workspace dependent.

If none of these are convenient, the default Blender keymap for toggling gizmo visibility is CTRL+~ on a North American keyboard, but I think that one key varies depending on what language keyboard you have.

Hey, thanks for making this addon available! It’s the common sense way of dealing with gizmos. :slight_smile:

Two things: I think it would be really helpful if the assigned hotkey tapped twice did not toggle the gizmo visibility. In my experience this way you end up hiding the gizmo by accident way too often.

Instead I’d like to recommend a change where you can assign a different hotkey to toggling visibility instead:
E.g. I use ‘M’ for the move tool (old habits). So in my opinion pressing M repeatedly should only ever activate the move gizmo - or do nothing if I’m already in that mode. SHIFT+M on the other hand could be dedicated to hiding the gizmo. No more accidental toggles.

Another thing that might be a bug or a limitation: From what I can see QWER seems to not toggle gizmos at all when used in a viewport that has been maximized?

Thanks for the bug report. I’ll look into that issue.

I see how being able to assign a separate hotkey for enable and disable. I’ll look into what I have to do to make that possible in an intuitive way.

I really like using the shift key for adding transform gizmos, myself. It’s nice for scene layout to have move and rotate enabled, for instance. But qwer_addon was always meant for custom workflows, so to each his own :grinning:.

1 Like

Any updates on this?

The current releases now also allow for gizmos in the UV editor which would be handy to include in this addon since they behave as counter intuitive as the 3D view ones out of the box.

I have zero time for coding lately. I’ll see if I can find the time to look into getting the 2d Gizmos working.

1 Like

Any chance we’ll see an update for QWER someday? :slight_smile: