Radeon HD 6950 + Linux; can't get any perforamce

Hi all,

I’m setting up a new desktop with the Radeon HD 6950 on Debian Linux (sid, gnome3) and I can’t get it to perform how it should with either the free driver or fglrx.

jacob@debian:~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6900 Series 
OpenGL version string: 4.2.11762 Compatibility Profile Context
jacob@debian:~$ update-alternatives --config glx
There are 2 choices for the alternative glx (providing /usr/lib/glx).

  Selection    Path                    Priority   Status
* 0            /usr/lib/fglrx           99        auto mode
  1            /usr/lib/fglrx           99        manual mode
  2            /usr/lib/mesa-diverted   5         manual mode
jacob@debian:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
10958 frames in 5.0 seconds = 2191.600 FPS
12114 frames in 5.0 seconds = 2422.800 FPS

System Settings > Graphics > Driver = VESA: 01

I don’t know why CPU use goes way up when I drag around the default 3D view in Blender, but it does. I don’t think it’s on software rendering because it starts getting really laggy at 200k polygons (it’s unusable at 300k,) and also GLSL works. My old nVidia 9400GT performs 1.5x faster than this card (!!!) I should be able to do 5kk polygons now, what is wrong!? What’s with this 200k lagging business!?

I am using a Radeon HD 69xx with the free drivers. Try installing the free drivers and check that glxinfo shows “direct rendering: Yes”.

Hi, thanks for the reply.

I can still only have around 250k polygons before it’s unusable. I still don’t know why CPU usage soars when moving around the 3D view with FBOs on.

this is my glxinfo now:

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CAYMAN
OpenGL version string: 2.1 Mesa 8.0.2
OpenGL shading language version string: 1.20

direct rendering: Yes

So I applied the subdivision modifier and now I can get 5kk polys with minimal to no lag. I guess Blender is doing something I can’t guess what.