Radiosity keeps stealing parts of my models.....


(sonix) #1

Help, has any one else noticed that Blender seems to remove meshes when rendering a radiosity image?

If I do a usual render, all objects are there, after doing the radiosity calculations and freeing the data, replace meshes etc., the meshes appear in the 3d window view, but hit render and parts seem to disappear.

Soon to have no hair left, I have had to resort to just normal renders, has anyone encountered this same problem?

Yes, have made all meshes single sided and the normals appear to be facing the correct way (outwards).

Sonix.


(S68) #2

Yes,

I had the same problem.

On a quite big scene radiosity created more than one single mesh with radio data, but renderer rendered just one of those mesh.

Quite sad, and I never found a workaround

Stefano


(Anton42) #3

I did have a similar problem, and I found a working solution for that somewhere on these forums. If the cause of your problem is the same as mine, this should help you :slight_smile:

Apparently, when radiosity is calulated, it generates many new materials for the scene (which contain shading info). There seems to be a limit on how many materials can be rendered by Blender (which, if true, is a shame), 16, if I remember right.

This can then be solved by Ctrl-J(oining) the meshes that have the same material before runnung Radiosity calc.

I had a simple “fire-place” scene, and it worked fine when I had ground, “fire” pyramid and several rocks around. Then I added a simple “person” and things started dissapearing. Then I joined all my rocks, and everything worked fine again.

Hope this helps.


(BgDM) #4

It is a material issue, as well as a vertex count issue I beleive. It only happens on large scenes.

The only other solution to it is to use Blender V 1.8 and do your radiosity calcs. For whatever reason, anything higher than 1.8 has issues with radiosity.

BgDM


(sonix) #5

Thanks for the posts, can you still get Blender V1.8? And if so where from?

Sonix


(theeth) #6

did you try spliting the mesh after the radiosity solution is calculated?

Martin


(sonix) #7

Martin,

Yes but not properly, I don’t think.

I thought (fool) that I only had to split the meshes if I am adding further textures to the radiosity material?

Yes /No ?

Cheers for the Help

Sonix


(theeth) #8

even if you want to add new textures, you don’t really have to split the mesh back, but just think about this a minute. When you applied the textures first, before the mesh were joined, they were mapped according to a texture space fitting this only object. Now that they are all joined together, the texture space has strecteched to englobe all the other objects, so it’s always better to split them afterward if you want to have the same texture mapping as you did before.

Martin


(sonix) #9

The thing is Martin, that I had no materials or textures on any of the objects in the scene.

I just wanted the default gl shading to apply. I need to retry what I was doing initially to see why the meshes disappear from the render.

Just had a thought … the scene is a couple of motorbikes in a garage. The wheels (Tyres) were missing. This might be due to the type of mesh shape that I used to create them. Will check and post back here.

Sonix.


(sonix) #10

Okay I’ve been playing with Blender and I have solved my disappearance problems.

Certain objects in the scene, the tyres for example, were not meshes.

Once I converted them to a mesh they were displayed in the final render.

This shows true for all Surfaces, Curves, Circles, and Metaballs.

Thankyou to all of you who have kindly offered words of advice and help.

Sonix.