Radius point light problem through window

Hi! ,

Could someone explain to me how I can adjust this glazing shader so as not to see the effect of the radius that we see from the outside to the inside, while it is invisible from the inside (render Cycles)?
I set a radius of 1m so as not to burn the ceiling with the light of the spot.
Thanks for your advices,

Light Point Radius|369x500

On the lamps, in the object properties, open up the visiblity tab and disable the checkboxes for Transmission and or Glossy.

If you have all the lamps selected you should be able to toggle all of them at once by holding Alt when you click on the toggle.

Thanks, I’ll try it.