Ram filling up while compositing with Use Backdrop

Hi there
Going to different frames while working on a rather heavy composite, my ram (16GB) gets gradually fills up, till my computer gives me a black screen and restarts (if I don’t restart blender before). Has anybody found a button or trick in order to empty the ram without having to close and restart blender every now and then? I hoped the Free Unused Button would do the job, but no. Maybe any settings in the Preferences?
Thanks for any ideas!

I’m working on a PC with Win8, 16GB Ram, i7-3770 3.40GHz CPU
Blender Version 2.67


You don’t have to use the backdrop, you could view the viewer node in UV/Image editor.
Anyway, you should try the latest Blender and also the development version (from http://builder.blender.org/download/) and see if the problem goes away. If it doesn’t, a test file should be prepared and reported to bug tracker.