Random crashes related to Nvidia Driver (nvoglv64.dll) in 2.91 - 2.92

Did anyone recently started to get random crashes in Blender? For me it is started since 2.91 but I can’t reproduce it constantly. Most of the time it happens after some action like switching to xray or showing wireframe. Crash logs show that it is somehow related to nvoglv64.dll driver.
I see people tried to report it already: https://developer.blender.org/T78117
but since it is hard to reproduce developers cant help much.
I’m on 2080TI with 461.40 Studio driver, W10 1909. Had the same issue with the previous studio drivers.

2.91.2 was crashing on me so I turned off autosave in preferences. That helped

I’ve been going nuts with this issue, no way to cause it on purpose. The only thing I found that’s kind of strange is somebody on adobe forums complaining about the same exact crash. I’m almost sure it’s nvidia doing something crapy, but who knows. It looks like there is no solution for this at all

And I found this - these devs think it’s nvidia: https://confluence.qps.nl/fledermaus7/installation-setup-and-configuration/fledermaus-keeps-crashing-nvidia-error-nvoglv64-dll

And their solution makes absolutely no difference.

And maybe using shift+z crashes it as much as random clicks.

me too! please contribute and give info about the addons you using:

ad your activated addons here please:

Well I tried disabling pretty much everything and it still crashed. However, I found a possible solution - tried adding this to my registry and haven’t had a crash since. But this is really hard to replicate, so I just might be having luck right now and waiting for the random crashes. I would like more people to try this so that we can find out if it is the solution: https://forums.x-plane.org/index.php?/forums/topic/200744-bug-report-nvoglv64dll/

The relevant part is below:

    1. Goto registry editor (start → run → regedit)
    1. Navigate yourself to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/GraphicsDrivers >(make sure GraphicsDrivers is highlighted).
    1. Right click → New → DWORD (32-bit) value → Name it: TdrDelay → double click it → Set it to A >(hexadecimal) or 10 (decimal).

This doesn’t solve the problem. It seems to help, but need others to test it

Hy @kobrad i have a value set because i use e-cycles and the developer recommends that you set the value to ~400 or so…sadly it didn’t help. did you have any addons activated? (also official ones).

Well it seems to have made it crash less often. And now I crash when I shift+z to wireframe it seems. I tried disabling all of my addons but it made no difference ( I only have botaniq and cad transform ). Anyway, this never crashed when using either of those, and it crashes with them enabled and disabled. nvogl64.dll is cursed

yes, but have you disabled the “official” addons that come with blender…? just checkin

I tried disabling everything I don’t use, can’t test it if I can’t use it. I left node wrangler on, some imports, not sure what else. Maybe I can try with everything disabled, but is it likely that the addons are the cause?

Okay. Time for my 2cents.
At first I thought it was just the latest iteration of Blender (2.92), but it isn’t. 2.83 LTS and 2.91 does the same thing. Memory usage goes through the roof, slow to respond, randomly crashes for no discerable reason. In one instance I simply tried to readjust the size of a window panel.

The only known difference I can track down is the most recent GeForce driver update.
So I am considering going back to the last driver as soon as I calm down (assuming I can get a download for it) to see if that makes a difference. For the moment, steady, reliable Blender isn’t anymore, and is now unusable. If anyone has an update on this (wether it is truly an Nvidia issue, or a Blender issue), do let us know. I know I’m not the only one here experiencing this. It seems to be across several forums.

I know it will everntually get worked out, but very frustrating at the moment


1 Like

I start to think it’s a combination of things: latest drivers + latest Blender.
Unfortunately, I can’t revert to old Nvidia drivers as it would break H265 support in DaVinci.

By the way, I’m getting crashes in the latest Affinity as well (they now use GPU acceleration).

So, here’s what I did which seems to help, but still testing (screenshots below):

  1. Tweaked the registry
  2. Tweaked Nvidia control panel
  3. Turned off most of the add-ons

Registry (following E-Cycles manual tips)

Nvidia (you need to enable developer settings)



You just need to google nvogl64.dll and you’ll find a whole bunch of software and people having these issues. I expected the studio driver to help but there is no difference at all. Did any of these things solve the crashes?

In fact that’s what I searched and that’s how I got the info about the GPU Performance Counters.

And apparently yes, it seems no more crashes but as I wrote, I’m still testing.

What I’ll do is check if with the current changes things get more stable. If they do, I’ll then start adding back the add-ons I turned off.

1 Like

From report file, tile size was 231x256, it’s always good to use squares with multiples of eight and scene has a volume but light path was set to zero. So I think he tryed to compensate with lightning which had a IES profile, very demanding.
Tweaking the scene I had a crash, Blender just vanished. Yet after I could work normally, and did a render (volume was removed). Took 20min on GPU Compute, my processor is i7-4700MQ and GPU GT740M.


I had that kind of problem when scene was consuming more vRAM than I had (probably not your case), so now I optmize everything. Crashes stoped. I don’t think this is a driver or dll problem, try to open this file and rendering, it’s a revised version. Add a volume, I’m quite sure that your systems can handle.

File: https://drive.google.com/file/d/12bsej4DvSytrITfsOgm1lsGVjtd3Bx9C/view?usp=sharing

I had crashes with two cubes in the scene, not sure what else it can be - and it never ever crashed on render for me, even when it had to stop for lack of vram for rendering it did that just fine.

That was actually my report. Im still learning Blender so im sure i made a ton off mistakes but the issue of crashes definitely wasn’t as scene related as it persisted with just doing edit mode with the default cube. Even when i upgraded to a 3070 Blender crashed with simple scenes.

For a while i used Linux to get around the crashes but i got tired of the OS. Ive got it to stop crashing on Windows by OC the ram and installing VC_redist.x64. Im not sure which one did the trick as i was testing out two theories at the same time but i can ran Blender for hours now without a crash.

I bet updated drivers solved the issue, because it wasn’t Blender alone that had this problem. I did absolutely nothing with my pc except update drivers (and blender) and now it all works without issue. As long as it works I’m happy