Random frames get darker during render

Hi im having a huge issue with my render, randomly some frames just get fully darker for no reason and it causees this flicker effect. I checked all the light sources, i cant figure out any reason for this to happen. Please help! im on a deadline.

What are your samples set at?

1 Like

350
It doesnt seem like a random render issue though, cause ive consistanly tried it on the same frames and those frames are always darker. it almost seems like theres a issue with the light, like it dims for 1 frame, cause look at the difference between these 2 frames

Do your lights have keyframed strength? Are they be clipped by an object or your clipping settings?

No I went back and looked at my dopesheet and the only thing that i see being animated at that time is the camera (and curve track that its on) as well as the plant being anymated. I have like over 20 plants that animate out of the ground. could those be doing anything to it. It almost seems like when their animation starts that it does the flash but theres no pattern, cause sometimes it doesnt and sometimes it does. Super confused.

how would this effect it

Any other thoughts on this? it seems like the lighting from every source just gets randomly less bright. I really needa figure this out if anyone else has thoughts, it only seems to happen once i get close to the ground and the plant animations start also.

Which renderer are you using? Does it happen in both?

If this is Eevee, I have had some objects with depth problems or flickering caused by motion blur. In a recent project, I had to increase the max blur setting because there was an object that rendered wrong when the motion blur was active.

1 Like

Your clip start value might be off.

1 Like

I couldn’t tell you the technical reason, only that it does. High values = less likelyhood of flickering.
(edit) for samples that is.

As far as I understand, renderers do some parts of the rendering process using the z pass (aka depth pass). The z pass is an image that stores the distance of every pixel seen by the camera. However, there is a limited number of possible depth values between the closest and farthest point of the render (Blender will only store a certain number of decimals in the depth value). This means that if there is too much distance between the clip start and the clip end, the different possible depth values will be spread too thin and you loose precision, Blender can’t reliably tell anymore which object is closer to the camera that which.

For this reason, you should keep the clip start as high as your scene allows without the camera clipping through objects and the clip end just close enough to cover the farthest point of the scene (you can leave some margin).

1 Like

Are you mean the clip start in the camera settings, this doesnt seem to help? i put it at like 4m but the spacific frames that are darker are still dark, it makes no sense, i dont understand how some frames are always darker and some arnt, like there is nothing wrong with my lighting, i dont have any weird keyframed lighting, and it is always the same frames, no matter what. it has to be some kind of key framed thing or some kind of bug

4m is far too high. Try .0001m

I did that, but also i have a development, i was continuing the render and realized that on one of them the HDRI is showing through slightly. I think this is whats causing the issue… Do you know why this could be happening?

I actually don’t expect it to be because of the clip distances, I was mostly responding to @Modron.

Like I said in my other response, I have mostly seen this kind of problem with Eevee’s motion blur.

But in a scene that large, it could be hard to tell without having access to the file.

https://drive.google.com/file/d/1y9UgjTA5QKhOJbB3HEY06M2m1EnDGXku/view?usp=sharing

Here is the file., Its very messy rn, cause i have most everything turned off in the scene for render speeds, this is a world that ive created multiple videos from for a client, so thats why its so big and im only using one section of it. Also i keep getting a freeze on Building Optix acceleration structure and have to skip to the next frame, lmk if you could figure out how to fix that aswell… idk why its being so buggy

I have done a low quality/low resolution test render. I had to use the cpu because my graphics card can’t fit the scene, and I didn’t get the problem. I am going to make a guess that it’s optix related.

Could you try doing a quick, low quality test on cuda and maybe one on cpu to see if that’s the case for you too?

As for the reason why optix bugs, I can suggest 2 theories:
-its just because of the sheer size of the scene
-there is a specific object or material that causes the bug.


For the size of the file:
Let’s start with the size, because you would benefit from a reduction even if it doesn’t solve the flicker problem.

The most obvious thing I notice is that you aren’t using instancing (also called linked duplicates).

If you have 2 objects that are completely identical, you can tell them to use the same mesh and this will save memory. It will reduce the size of the blend file, and as long as you don’t have any modifier on the objects, it will also reduce the memory use at render. Also, if you modify the mesh on one of the objects, they will all change together, so make sure you use this only on objects that really will stay the same.

If you have 2 objects that are the same, you can go to their mesh settings and replace their mesh in the dropdown menu with an other one (you can also select them all and use ctrl+L → link object data). If you set all identical objects to use the same mesh, you will see the scene’s polygon count go down and the performance will improve.

When you duplicate an object, you can use alt+d instead of shift+d and it will directly make an instance of that object.


If it’s not the size causing the problem

Then you should try making a copy of the file and deleting things one by one until you find the object causing the issue.

Start by deleting everything that’s hidden, just to make sure it’s not something in there causing it. After deleting, then use recursive cleanup to make sure it’s all really gone.

Then delete objects by type: delete all mountains, then all trees, then all crystals, until there is almost nothing left in the scene, doing cleanups in between. If it still happens, you will have probably narrowed down the problem to what’s left.

1 Like