Random proportional editing doesnt work in Obj mode[ EDIT]

Is this a bug or what ? Random proportional editing doesnt work in Obj mode… i need so rnadomly scale many objects… any other idea ?


the way it doesnt work is in OBJ mode with individual center and then scale in random mode… try it…

spacebar -> randomize tranform… :slight_smile:

Works fine here

I think the “proportional editing in object mode doesn’t work” is because the proportional circle is small by default (it’s smaller than the default cube), so you need to increase its size (with the mousewheel or the pageup key) to see actually work and affect the other objects around.

i doubt it can work in ob mode
the name says it
it is in edit mode only!

i tested it on a cube and prop scale does not work in object mode

happy bl

Proportional Editing works in Object mode
Add a bunch of cubes in Object mode, select only one, enable proportional editing, press S and increase the proportional circle and you’ll see.

select only one

I think that’s the key. If you select everything, they’ll scale equally. Select one, and every object within the circle of influence will be scaled proportionally.

Not entirely sure what the purpose of this comment is - it clearly works and you simply never tested it correctly.

@TweakingKnobs - make sure the origins of the objects are where they should be - not all in the same place and also within range of the proportional edit circle of course. Proportional edit in object mode manipulates the objects from their origins (aka pivot point), you can think of them like vertices with an object attached, it does not edit all the meshes at once but simple the location/rotation/scale of each object as a whole.

As JA12 shows, it’s definitely possible, works just fine and is one of my favourite features in blender.

at my home works ( i tried it in my job )… strange… allright so its al good :slight_smile:

ok never been a big user of prop edit!

would be nice to see a short video showing this
including the random transform
cannot see it work on win!


Win7 Ultimate 64 bit, Blender 64bit, r 60695

i can see do this random move
but how what sequence of commands did you use?

i see the proper edit random selected but what else after that ?

did you use the operator random tansform may be from space bar ?


Grab command from the keyboard. G+X,G+Y and G+Z

something is missing not working
if i do G X all objects move at same time no random at all!
i can see the circle and random is on !

what is missing ?


Ricky, select a cube in the middle of several of them in Object mode, enable proportional (and set it to random) then pressed G and Z , increase the circle range and move the cube up.
Do not press Enter or Left Click but take a screenshot of what you see on screen so we can give a look at what you are doing wrong.

Select only one object, if you select all, all move like without proportionally mode.

are there any user pref setting for that?


Try with File -> Load Factory Settings, and try again then to see if it’s one of your custom setting/addon that is giving you problem.

tried the factory settings and discovered something
if the circle is covering the area where obs are it does not work!

but if you make circle larger then it begins slowly to work !
the larger it is the more effect it has and random it becomes!

i dont not use this feature very often for mechanical design

and usualy i work at close distance with ob so when you use this prop circle
it hits the window sides fast!

thanks for your patience

You can use the mouse wheel to adjust the circle size.

It works very well for mechanical stuff,it helped me tons when i modeled propellers and some tubes (i know you can create a tube with a bezier curve with a bevel as a circle but i didn’t feel like attaching a new mesh to my object)

You need to read a bit more what people post.