Random vertices are selected when selecting circular select

Random vertices outside the selection area are selected when I use the circle select tool. This only happens when display mode isn’t wireframe and selection is limited to visible. Box select is also affected.

The strange behavour began seemingly out of the blue, but after I toggled experimental feature set on and off and after I unintentionally pressed a couple of buttons in rapid succession, so I might have unknowingly triggered some option.

Happens with 2.79 and 2.79a.

Bug or feature?


Change the selection method in user preferences -> system.

None of the combinations of ‘Selection’ + ‘OpenGL Depth Picking’ on/off fixes the issue.

Try copying the mesh into a fresh file maybe?

I tried first adding a sphere and Susanne in a new project and then importing the mesh into it. In all cases the issue persisted. The issue was present with all meshes in the other file, too. It seems it stems from Blender itself and its settings instead of a particular mesh.

can you upload the file so we test it

happy bl

Here’s an example file that shows the issue.

Attachments

test file.blend (3.97 MB)

nothing out of normal for selection on object

I would suggest just re install blender and re test it !
and let us know if it works OK

happy bl

I reextracted blender from the zip and the issue persist in the default scene with just a torus added in. It’s even present in a 2.8 build I downloaded some time ago. All of that after resetting to the factory default twice.And yet the issue appeared just yesterday. It’s as if it’s some setting stored somewhere on the computer - is that a thing?

No. Most likely culprit is the gpu drivers or their settings, as mentioned in many of the reports
https://developer.blender.org/T45284
https://developer.blender.org/T38523
https://developer.blender.org/T50631

Run Blender with softwaregl to test that. It will be slow, but if the selection works as it’s supposed to, it’s a driver or driver setting problem.

Yup, it’s that. And since it appeared mid-session, it seems it’s a driver setting issue rather a driver one. I just hope someone on the internet will have figured it out.

Edit: Changing some Blender settings fixed the issue. I think it was ‘Anisotropic filtering’ to 2x and ‘Window draw method’ to ‘Automatic’, ‘Multisample: 8’, both in system section.