Random vertices on my model not moving with armature

Hello everyone!

I haven’t done any rigging in blender in close to 10 years (yikes!) and decided to give it a crack today. unfortunately i’m running into a bit of a problem. there are a few vertices that don’t move with my armature. I have made sure that those verts are in the vertex group for the bone that is supposed to be affecting them, also I made sure they weren’t weight painted differently. Do you guys know anything else I can try?

https://www.dropbox.com/s/ffdf5vj00927v95/badface.jpg

Obvious, dumb question: in the group-- but with any weight? You can have a 0 weight and still be in a vertex group.

Any modifiers? Disable and see if problems persist. (Including a mirror mod, you might not have mirrored groups set up right.)

Do the affected verts belong to any other vertex groups? Even a slight weight from a distant bone can send them off into the sunset.

Feel free to link a .blend if you can’t figure it out.

I tried applying my modifiers and that didn’t help. I honestly don’t know anything at all about weights. I tried painting everything red??? (i’m clueless). I added my blend file to the post. I’m sure its an easy fix.


The problem is that the head bone is weightpainted to affect the entire body not just the head.
Remove the weight from the entire body and just leave the head red for that head bone.

I tried it and it didn’t work. Perhaps I misunderstood something?

https://www.dropbox.com/s/b8ntto8e7499bim/head.jpg?dl=0

You have to make sure the head bone is selected before weight painting. You had some extra bones that were painted to the entire body.


I removed the extra bones weights
NewPles.blend (1.5 MB)

Ah!I understand! Thank you guys so much for your time and effort. it is greatly appreciated.

1 Like