"Randomize" under Mesh tools under Deform is Overpowered.

Hi, I am having some issues with this tool. It’s way over powered, how do I make it more subtle?


Now AFTER I use that randomize feature.


How would I go about fixing this?

Immediately After you click “Randomize”, press F6 to bring up the options. Or just look for the same options at the bottom of the toolshelf.

thanks that did the trick.