Ray shadows in linked object are weird

This problem is now solved.

When I render my scene with shadows turned on in the render panel I get weird results as pictured in machine_bottom_shadows.jpeg. When I turn off shadows it renders fine.

The tennis machine and environment (which has lights) are linked from separate blender files. The bottom of the machine had the mirror modifier applied to resolve a UV texturing issue. There is a Subsurf modifier set to one level and the faces are smooth. I’ve already tried recalculating the normals in edit mode but that didn’t work.

There are 3 lamps in the environment that cast shadows. They have Ray Shadow turned on, Adaptive QMC, Soft Size of 20, Samples 4, Threshold 0.001. Two lamps do not have specular enabled.

I should also mention that when I render the machine in it’s blender file with a few spot lights there is no problem.

Does anyone have any idea why this would happen?

Solution:
I figured out the problem now. It turns out the modifiers are not linked but copied instead. Once I removed the mirror modifier in my scene the problem went away.

Attachments