Ray Transparency and Hair Particles..?

I figure this is a simple oversight on my part somewhere.

I’ve made a pair of eyeglasses, with the lenses set to ray transparency with all default settings. The character the glasses are for uses particle hair for eyelashes, which also use ray transparency.

Now, with the camera looking right into the character’s face, through the lenses from the front, the eyelashes aren’t there; however, with the camera looking at the character’s eyes from the side, bypassing the lenses, the eyelashes are visible.

What setting do I need to tweak (assumedly in the ‘Ray Transparency’ panel) so the eyelashes are visible through the lenses?

Thanks in advance for any help!

Oh, also, I’m curious as to what setting to use for the lenses’ IOR. Has anyone experimented with ray transparency for eyeglass lenses?

I think that’s because you can’t drop shadow on strands unless you use buf.shadows.
Try with a spot lamp to see if it works.

Are you sure you haven’t enabled the ZTransp button for the eyelashes? Ztrans is invisible to raytracing. Is ray tracing enabled for your render also? (F10 - render tab). The IOR for your spectacles are going to depend on the (apparent) thickness of the lenses. Thicker lenses == more distortion, e.g. Coke bottle glasses.

Yeah, both the lens and eyelashes have Ray Transparency enabled, and both have ZTransp disabled, and Raytracing is enabled in the Render panel.

I did find that by setting the lenses to ZTransp and leaving the eyelashes with Ray Transp, the eyelashes are visible through the lenses. Superficially, this seems hackish, though, and I assume it must circumvent some of the shading (be it specularity or whatever).

Could it have something to do with the key light being an Area lamp?

I tried it last night and it worked for me but I was using a sun lamp.

Works with area lights too. Have a look: