Raytracing, transparency, and shadowing prroblems

Hi all,

I’m having a strange problem with raytracing, transparent material, and shadows. I created a test scene to demonstrate.

The scene consists of a grey floor with a red cube above it. Above the cube is some glass and above that is the light. The light is initially set with Ray Shaodows turned off, the result is as follows:


As you can see, no shadows from the cube. So i turn Ray Shadows on, and I get:


Why is the glass casting a shadow?! I can’t get rid of this, can someone tell me what i’m doing wrong? You can get the sample scene at:




ray shadows don’t care about the material of the object casting a shadow unless you tell them to

press trashadow for the material on the plane [recieving the shadow]

Your right, you know :smiley: Though it seemsw odd that the setting isn’t on by default for materials, maybe a sped thing. Works now so thanks!