raytracing with mist problem

I’ve been having a problem with using transparent materials in mist. I’m no noob with blender. Trust me, I’ve tried many different things to get this to work. I know ztransp works in mist, but I have a project that needs to have raytracing.

using ztransp, here is how it should look:

If image dousn’t show up -> http://www.deviantart.com/view/23085282/

With ray transp, this is what I get:

If image doesn’t show up -> http://www.deviantart.com/view/23085236/

Here is a shot of the mist settings:

link -> http://www.deviantart.com/view/23085371/

What is your lights setup?

Edit: ok i experimented some, and it seems, that the planes are darker, beacouse, when you enable Raytracing the mist is raytraced, casting shadows on the planes. You can see that by clicking the “Only Shadow” button in the material settings.

Partial solution is to enable the “No Mist” button, and change the objects transparency, so the further from camera, the more transparent the object is.

and it seems, that the planes are darker, beacouse, when you enable Raytracing the mist is raytraced, casting shadows on the planes

I don’t think it is a shadow. it looks like mist with raytransparency is calculated wrong.

Here’s a test with Blender 2.36. Mist seems to be calculated correct but not behind the transparent planes.

The same scene with Blender 2.37a.

Bug or feature?

Are you using the unified renderer? If so I’ve seen some pretty interesting problems with Mist and the unified renderer.

My examples above are not rendered with the unified renderer. I tried it and it gave different results, but not better.

Working with 23.7a here and tried to re-create fade to black problem. Mist seems to be working better than expected here. Not sure what drugs Softworks and Braindamage are taking. Curious to find out though…

I only have problems if I use raytracing and mist with the unified renderer. It will create a strange transperant layering image. Other than that, mist has always worked for me just fine.

(except in Yafray, but that’s not a Blender issue.)

best you can find in the states. lol.

anyway, I should point out that I am using windows xp. not linux or anythig else. Could be the problem is only on windows. also I am using the newest version of blender.

as for using the unified renderer, I just get different problems. not to mention it takes longer with it.

thanks for the help so far.

Doing XP here, so shouldn’t be different. Try lowering the Mist Hi settings to around 3.2 [ 0 seems to have the same affect as 100 ] Try Sta from 0 [Zero]. Didn’t realise how sensitive mist is, but if you get out of it’s range it doesn’t seem to update :-? Tried it more than three times, and one time it was unexplainably odd…