real fps framerate?


How can i see the real fps framerate because if i turn on show framerate and profile options the frame is always (about) 60 fps but i think it is more than 60 :slight_smile: .
Can i disable this restirction or turn on real fps count, it would be useful for real testing for game engine speed.

Have a nice day!


The fps you see in blenders game engin, is the real fps as far I know.
The reason why it’s that low, it because when developers coded on it, never thought about performance but new stuff. Now I might change when the bullets physics are fully implanted as well that Erwin told he’s checking if he can do something with the performance and improve it.

Right now the fps shown is the fps you got on that game. :slight_smile:

%| Well… might be yes or no. It should be the fps you get in game, but for some odd reason it get’s jittery in fps mode if you’re running a low framerate. If fps is off for that particular .blend file, then everything runs smoothly. Not to mention, for some odd reason games seem to run faster on runtimes as well. But that’s just how it seems… lol not sure if it’s true.

edem you could be having some trouble with your vid card. I don’t know what the fix was, but for a time my desktop vid card was running any .blend at around 120 fps, no matter if it was the Atlantis file or just a cube in a blank scene. %| You could probably well have the same problem, hehe.

Jason Lin


so I pressume that you are under windows, some system’s set the default max tic rate to 60 fps, no matter what game you run, if your game is too heavy this 60 fps will go down, but never up.
Check out your video cards manual to see how to disable this limitation, or use Linux :smiley:

See ya.


Thanks for all!

yes dreamkatana have true :slight_smile: but this restriction occured only with blender because other gameengine and games run more than 60.
So if i (set video card settings) turn off Vertical sync and Application-controlled and leave turn off, it
will works. So i think blender use Vertical sync on automatically.
thanks agan.

Have a nice day!


I don’t know if you noticed, but the framerate one Blender 2.41 seems to be wonky.

For example, according the the framerate profile, the FPS should be around 160. But it seems as if its running at 25 or less. I do not have this problem in any other versions of blender. Maybe i should start a new post about this…

If you want to have a higher framerate, you’ve gotta turn what’s called Vsync off.

Vsync makes the highest possible framerate equal to the current refresh rate of the monitor. If the framerate of the game gets too much larger than the refresh rate, you can get some visual artifacts.

There really isn’t any reason to turn off Vsync, your monitor will still only refresh 60 times a second…


yes. just only reason when u want to optimailzed your game for a specialized configuration.
i.e. when u see that u have great deal of fps u can raise poly count or add some effect for better beautiful visualization.



but still keep in mind that some people might no have as good computer as yours so keep the models at a reasonable poly count so that it will run on other machines also…