Real Glass + Light shining trough


(Migeater1) #1

Hi , first of all , want to say Hello to the community , just registered , and i hope on a good collarboration :slight_smile: , and now im going to post the question ,

I know Blender is not a raytracer , but i got some glass , and a spot, now , i want to let the light show trough the glass , but , behind the glass there is no light , i put Ztransp on also alpha is down :wink: , but dont have any idea why it shouldnt work , the light is a spot with halo … Ive got an image …

http://mitglied.lycos.de/ifidefeuru/test.jpeg

U see , the uvsphere has no Halo light , cuz it doesnt go through the “glass” , i know the glass suxx ;D , but its just a test , is there any button i have to activate for this ?

And another question , its on particles , i have an candle , with an halo behind it … and look at this >
http://mitglied.lycos.de/ifidefeuru/test1.jpeg

Ok , i dont have any idea for this one … so , hehe , lets see if u got some :slight_smile: .

Thx very much :slight_smile:

Cu , Migeater

ps: Where can i send the gallery to ?? on the gallery send button i just come to the news again ![/img]


(Dittohead) #2

The first one:
I have no idea.

The second one:
Change the alpha on the halo material for the particle system, then turn on xalpha and change the color some until it looks right.

oh on a side note change the mapping for the table wood texture from FLAT to CUBE. that way you won’t get that streaking on the side of the table.


(meestaplu) #3

I’ve had the problem with glass and lights before.

// Please correct me if I’m wrong…

From what I remember, lamps do not shine through any objects containing physical geometry (translation: meshes, surfaces, etc.) This is the case even if the object is transparent - Blender is not a raytracer, so it assumes that all objects block light.

// This section is pretty much useless for what you want to do
// I’m pretty sure kos’s “traceable” suggestion is much better

If you want to fake light shining through the glass, you need to put the glass in a separate layer. Then, in the layer with everything but the glass, duplicate your spotlight and set the brightness down on the duplicate. Then, set the layer attribute on the spotlight you just made – that way, objects in other layers will not affect where the light falls.

The candle problem?
I have no idea.


(kos) #4

for your 1st question…just disable the “traceble” button in the meterial properties window(in the same column of “ZTransp”).i hope it will work.