Real time reflections and shadows

I’ve done a little reading on the subject and apparently Blender needs to run in GLSL mode for these to work. I would rather not do that as GLSL seems to only work on a selected few cards, so is there any other way to do these? I would need them for my simple game.

Hi DataNalle, maybe “on a selected few cards” is a strong expression! Any 2-4 years old card would run it! My workstation has a builtin chipset that runs GLSL (not very fast but…it runs nonetheless).
The fastest way to get realtime dynamic shadows and reflections is to use GLSL! Though reflections are still a bit limited to flat surfaces.
Other ways to do it is to fake it.

  1. In textured faces mode you can have an image mapped as reflection, and bake shadows into static object’s textures. You could also use vertex painting to add darkess to certain areas to fake shadow.

  2. You can also use material nodes to “paint” dark areas.

  3. you can use in Multitexture mode a lamp set to negative at the bottom of an object to make a blob shadow!

Some times you just need to come up with one or various creative ways to make shadows, and reflections, but mind your performance, normally those 2 take a lot of attention from the rasterizer!

My card is new and I just get a white screen (All materials are shadeless white.) with GLSL. I was kinda wanting this type of reflection: http://www.youtube.com/watch?v=BVD8knvRK68 I working on a simple marble game.

Also, how about transparency? Static shadows?

For that kind of reflection, you’ll need a cubemap reflection! Check around for that! But you’ll definitely need GLSL!
Also what is your card?

Static Shadows, bake 'em. Transparency can be turned on in the Material Options.

but… »all materials are shadeless white«…
… so, what else than just a plain white Screen would you expect??

ATI Radeon HD 5870 v2

I have turned on transparency (Yes I adjusted the alpha.) but when I press P my ball is still solid.

Pardon. My head works faster than I can type at times. I do have proper materials for all objects, but when I start the game in GLSL mode everything apart from the sky is shadeless white.

That card uses similar architecture to mine and identical drivers yet I have no problem with GLSL, something is not right in your setup, either you are using GLSL incorrectly or you need to update your drivers…

I bet I’m using it incorrectly. I guess it needs more than just clicking the GLSL button in the render tab? Also there is something wrong with the UV texturing. I baked the shadows succesfully, UV mapped it correctly yet when I run the game the objects are shadeless.

Use textures on your materials, and enable UV mapping, as well - both are in the texture panel.

In the 3D View header, make sure you are set to textured mode instead of solid mode. Everything tends to show up when in solid mode :wink:

I`m having the exactly same problem
My video card is a Geforce GTX 460M
I downloaded all the realtime reflections blend files around and none of em worked, all i got was that white shadeless screen…
ANd yes, I was sure about tex mode
Can anyone help? xD