Really Big Grass Blade Simulations

I have made a grass blade. It is big and I only intend to use a few in a scene I’m doing. I’m trying to get the simulations working properly but things aren’t going to plan.

My first attempt used a cloth sim (note that there was not center vein ridge going up the center). I added lighting+a wind force field. It did exactly what it it should do; it fell to the ground (except where I weight painted for pinning) in a crumpled heap just like a towel might.

My second attempt involved the same mesh only with a soft body sim. My force feild was too strong and for some reason moved the whole mesh to the right with only a little jiggling in the first few frames.

My final attempt included a more realistic grass blade mesh with a ridge going up the center. For some reason after applying a single force+soft body the grass blade inflated for no apparent reason.

How might I get it to look like it is swaying slightly in a breeze? Any help will be appreciated.

Thanks! Now I can stop scratching my head and get back to work!

Some possibly helpful tips – the number of keypoints on the hair strands determines the “flexing shape” of the grass blades. Too many and it gets all wiry-looking, so keep them to a minimum. Use the Weight tool in Particle mode to alter the stiffness of the blades – heavier weight (higher value) means stiffer response to Wind. The Length tool is great for varying the height of the grass, or you can Cut it as well, but use a smallish brush for the latter. Use a Blend texture Mapped with Strand to vary the color/texture of the blades along their length. Use a Traceable Material rather than Strand Render for long grasses – it can take longer to render but the cast shadows can add a great sense of depth to the scene.

I have tried to get wind to work with grass in the past but I have had no luck.

In this scene I have a clump of grass, which is a softbody mesh. I also have an Empty with a force field of Wind applied. I have added a noise modifier to the strength of the wind to give it a random value. The wind does not seem to affect the mesh.

What is the trick to making the wind affect the softbody?

I have the cloth settings set to silk and while the grass does collapse under it’s own weight, it does not respond to the wind.

Attachments

26_grass_soft_body_wind.blend (196 KB)


Here’s a .blend of the beach grass from my Nezina-Amber Gatherer scene. It uses a hair emitter and a Wind Field, gets good flex on the blades, can be adjusted in many ways – field strengths, parent strand flex, hair dynamics settings, child strand properties, etc.

GrassDemo.blend (580 KB)

Thanks Chipmasque, that is very helpful. I also was under the impression that I had to use something other than just the particles’ physics.

So what if I don’t want to use strands and want to use my mesh, posted above?

Can Blender wind affect softbody meshes?

Really nice…

Dermatologi.no

Yes.

Oh, you also want to know how?

OK, my bad. :wink: In the file you supplied, with the grass set up as Cloth, you can either jack up the Wind Field force level, or set the Cloth Field Weights parameter for Wind way up around 100. Wind has a very broad range of influence values, so sometimes you have to beef it up to see the effect.

Same situation for Soft Body. You didn’t have a Goal vertex group assigned so the entire clump will oscillate back & forth with your current Wind settings, but it does react to the force when it’s strong enough or the physics mesh is sensitive enough.

@chipmasque: Thank you once again. The mention of Field Weights for cloth finally sinks in. I noticed in your particle example that you had increased the field weight to 10.0. I wondered how to do that for cloth and never really noticed that cloth had the same exact field weight panel as particles (at the bottom of the panel, closed by default).

So for my example file I set the cloth field weight for gravity to 0.0. I increase wind to 200.0 then turned up the amplitude of the f-curve noise modifier. I am finally getting some wind action out of the mesh.

Just a work-flow note here. It is easy to make an adjustment then click play and wonder why it is not working. You have to bake every single time you make a change. Just thought I’d mention this to anyone messing with the example file.

Field Weights for the physics sims is a good way to get a variety of responses in the same scene without having to use a variety of Fields. The same wind can affect grass, tree branches, water surface, whatever, with differing results that can be tuned in the physics context rather than at the Field level.

And, yeah, baking is always the better way to go. Some physics will display OK just hitting ALT+A or the Timeline Play button but usually they glitch out in some way if not baked. One thing I found in 2.61 (haven’t checked 2.62 yet) is that the “Bake All Dynamics” option doesn’t seem to be working as it used to, which is a pain if you have a number of sims in the same scene.