Really need help with uv mapping.

I created a low poly mesh in blender, marked in the seams and done a uv unwrap.

I then exported the mesh as OBJ, imported it to ZBrush and done some high res sculpting, created a normal, and a displacement map in zbrush and saved them as Bitmaps,

I then exported the new low poly mesh from zbrush (UV’s intact)

In blender again, i import the new low poly mesh, and open the norm and disp maps in the uv image editor,

In the shading tab, i load the maps from image, set the normal as normal, in map input - set to UV, in map output - click normal (and adjust the slider).

However when i render my scene, the model looks terrible, still just a low poly mesh.

How do i render and image with all my maps applied and visible in the final render???

Been struggling with this for a long time now, followed numerous tutorials, yet nothing seems to work. PLEASE HELP.

When you select Normal in the ‘Map Image’ panel did you select Tangent as the normal space?
For the displacement map apply it using the displace modifier not in the material settings.

Cheers for the quick reply, yeah i did select tangent, (the bit right next to where you click on normal)

Iv not tried using a displace modifier, will give it a bash, see how it goes. cheers again mate.

Hey man, that did work with the displace, (didnt look to good, but can at least play about now) Iv uploaded a blend of the model, a normal map, a displace map and a really really quick texture map (for some colour at least) would somone mind taking a wee look at it? and let me know if its something iv done wrong in the earlier modelling process.

poliwrath .blend (262 KB)




This has just the colour and normal map applied (using the images from your previous post as there were no textures included). Your model had two material slots applied to it, this happens when you import from zbrush. Make sure to delete these slots first or make sure you are applying your textures to the correct material.
poliwrath1.blend (118 KB)

Cheers again for the help mate, i see what you mean, in the editing panel, under links and materials. Thankyou so much, that had been annoying me for so long.

Delete material slots

Iv done what you said with deleting the materials, iv applied my maps, went through your file and compared it to this one, from what i can see they are set up the same, but i must still be missing something as my render is still all polygony. plus in the 3d view, my model aint displaying the maps, while yours is.

poliwrath.blend (289 KB)

I take it to smooth out out the mesh you just hit the set smooth button, only problem im having now is getting the model to show in the 3d view with both colour and normal maps visible. And when i run the game engine only the normal maps appears

sweet i got it, just go to the game menu and enable glsl materials