really nooby questions lol :D

  1. how do you make things more than 1 color?
  2. when i turn on my game why is every thing shadeless even though i
    didnt click on the shadeless button? can you tell me how to fix it?
  3. when i start the game everything i subsurfed goes back to their original
    shape; how can i fix this?

if you answer please dont give me useless info like they did on my last thread:D :smiley: :smiley:

  1. I think you need to texture to give things more than one color. That’s what I do anyway. You can texture with a solid color.

  2. Everything might look shadeless because you don’t have mode set to texture. If it’s on solid, it looks shadeless.

  3. Subsurfing isn’t supported in the game engine. Polygons are expensive in games, so most of the time we use low poly modeling. You can make your subsurf model into an object (subsurfing is a modifier). By pressing control-c I think.


  2. to make objects lighted you press “f” then go to the face select buttons and press lighting or lighted or omething

3.what fireside said

and we didnt give you useless answers in the other thread you didnt andwer our questions

like where did it say 150 000 and 150 000 what…

when he saves, I think that’s where he saw 150 00

  1. Or you can press the apply button on the modifier.
  1. You can also go to edit, click on new on the first box to get a new material, then go to materials and choose what material you want to be the 2nd color by changing it to the number of material you want to. Then select the faces you want to apply the color on and in edit, press assign.

I’m bad at explaining this.

  1. You can either UV map or use multiple materials (check blender’s site)

  2. There can be 2 ways to get shaded maps/colours:
    a) If using Blender’s materials in GE you can just go to “Shaded”
    b) If using a UV texture, select all the faces you want to have shaded or just hit the A Key and press W then you will see a menu pop up and click the first “Light” that appears.

  1. Subsurf doesn’t work with the game engine. If you want your model more smooth subdivide it first and then click smooth. Subdivide Smooth never really works… It just throws vertices everywhere.

Good luck!

  1. Either use a texture as has been suggested, or for simple multi-colored objects, set the vertex color for each face in UV Face Select mode.

  2. By default, all of your objects should be shaded, unless you’ve messed with the face settings. Check for these two things before trying anything else:

  • Check to make sure there is a lamp in the same layer as your game object (or at least affecting that layer). Shading won’t work if there is no light source to affect the objects.
  • Make sure you have the 3D View set to the appropriate draw type. Default draw type is “Solid” which will always give you a shadeless, textureless look in the game engine regardless of what you have done with face mode. Press [D] over the 3D view to get the menu, and select “Shaded” or “Textured”. Shaded with show you lighting with no textures or world (background color), Textured will show you the way the game will actually look when run by the BlenderPlayer. Alternately, you can use shotcut keys to change the draw type. [Z] switches between Wireframe and Solid, [Shift+Z] is Shaded, and [Alt+Z] is Textured. If you have lighting and you have the right draw type, but you are still getting a shadeless look, then something needs changed in face mode. You can probably fix it by entering face mode (press [F] over the 3D viewport), making sure all faces are selected (use the [A] key), clicking “Light” in the Texture Face buttons of in the Edit buttons window ([F9]), then clicking “Copy Draw Mode”.

I apologize for the noob question, but I cannot locate the ‘apply’ button. I am using 2.42; just started and I am walking through the wiki tutorials. When I tried to apply a new material to selected faces (“Die another way”) I realized that my ‘Links and Pipeline’ tab did not have an “Apply” button. Am I looking in the wrong place?

Thank you,

Apply button (the one they were talking about) has to do with subsurfing, when you are modeling, you can see your result without applying the subsurf modifier. This gives you better control over your model when still working on it. Once you have what you want, apply modifier and it will have much more polys when going in edit mode (depending on a level of subsufing). Only now the game engine will show you subsurfed model instead of the original one.
About shading, guys allready told you what you asked but now when speaking of it I have a question about shading:
-while making a game with UV textures there are a lot of tricks of making shading look realistic so I was wondering if anyone could share some of them? To rephrase that: what do you do about shading in game engine:confused::confused::confused:

Alt + C will convert your sub-surfed mesh into a regular mesh.

Gah! Clear lack of observation skills. The Link and Pipeline tab is different in materials mode than in Edit mode (which reads Link and Materials). My apologies, and thank you for the conversion shortcut.