Really slow rendering problem

I’ve started using Blender not a long time ago, and this is one of my first projects. As a newbie, I’m probably doing something wrong with the render options. So I was rendering 1 frame per 2 mins, and I managed to render 100 frames yesterday, until I came across this error - “CUDA error at cuCtxCreate: Illegal address” and I wasn’t able to render anymore, so I had to change some render settings. I managed to fix the problem, but now the rendering takes way too long.

I’m rendering with GPU only, before the error I was using both CPU and GPU, but now it doesn’t seem to be as fast as it used to be.

The render slows down a lot when getting closer to the finish.


Same render, but this one is when I took the pic way earlier, it says it will be finished in 2 mins, but when waiting longer, the render time goes all the way to ~12 minutes per frame…

Notes: I must keep the 1920x1080 resolution. I’ve been playing around with rendering settings, turned volumetrics off, ambient occlusion too, I’ve baked everything including animations. Found the sweet spot for the tile size (256), but it isn’t enough. I lowered the subdivisions in “Simplify” tab to 2, decreased rendering samples to 64. I’m double sure that I’m using CUDA with GPU only selected, and also the GPU compute option selected.

What I might be suspicious of, is my denoiser in the “Compositing” workspace, I’ve seen on the internet that it helps to speed the rendering up and also removes all of the noise, but then also that CUDA error appeared after I added it and rendered 100 frames, but it might be a problem with my scene only, I don’t really know anymore.

My specs:

  • Processor - Intel® Core™ i7-9750H CPU @ 2.60GHz 260GHz;
  • RAM - 8.00 GB;
  • The program is installed on SSD disc;
  • Windows 10 Home 64 bit (version 1809);
  • GPU - NVIDIA GeForce GTX 1650 4 GB.

Any suggestions are welcome, because this animation is around ~800 frames, and later on I will have to film the scene from different angles, and I’m nearing to my deadline.

My project’s “.blend” file - https://we.tl/t-3gWUmeCVMO (~1,2 GB).

If your file itself is 1.2GB, I feel like your original error may have been due to running out of video memory.

Having to reduce the number of compute devices will increase your render time. Can you do anything to make your file smaller?

Here’s what worked for me:

I went into Edit > Preferences > System, and unchecked “Global undo”, the result was totally unexpected. Everything started to work as if I started a new project which has a cube only. Of course, I can’t undo anymore, but it’s unnecessary now and also it takes half a minute to undo something. Rendering times dropped to 2 minutes, and the feeling is just holy.

Thanks for the help, also what do you mean by the compute devices? I looked at the internet for it, but the feature is for 2.7 only I think, I can’t find it on 2.8.

Read over this thread for a possible explanation on why this change worked and why linking will help manage larger scenes:

relevant portion by dr. Sybren:

The undo buffer works by actually saving the entire blend file in memory, and loading it to undo. If you have such big, complex files, that’ll take a while.

A possible way to speed things up would be to enable Simplify (scene properties panel) to restrict the subdivision level, and to write parts of the scene to different blend files and link them into the scene (rather than having all data in one blend file).

1 Like

“CUDA error at cuCtxCreate: Illegal address”

May be three problems:

  1. Not enough GPU memory.
  2. Your GPU memory may have broken parts. Check your GPU memory health.
  3. Blender bug.
1 Like

So, even though some of the references to “Compute Devices” still exist (https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html#can-multiple-gpus-be-used-for-rendering) it looks like the section has been renamed to “Cycles Render Devices” in newer versions of Blender. It is under Preferences > System > Cycles Render Devices.

1 Like

It’s hard to tell. It got fixed now when I brought the old settings where I was having the problem. It’s probably the undo option which saves like 32 steps for every 2 million objects which most of it are grass and leaves. At least now I’ll know what to keep in mind next time. Thanks everyone!