Really weird shading issue...

Notice how the shading has a lot of edges? This a is a problem with the mesh, though the normal map makes it more apparent.

Yes, smooth shading IS on.

What’s going on here and how do I fix it!?

My telepathic sense tells me you forgot to switch the normal map to ‘Non-Color Data’ again. But if my telepathic sense fails me, then at least show the edit mode screenshot and material nodes setup.

It is set to non-color.
Here is the requested screenshot.

I’m pretty sure it’s a mesh issue, it has the same issue in Modo.

Oh, wait, does it look like that only in rendered viewport, or on render as well?

Both of them.

Then check the usual suspects: double vertices, inconsistent normals (you showed the textured edit mode, not solid, unfortunately), internal faces, other non-manifolds…

I removed doubles and recalculated. What/ how do I remove inconsistent normals? Internal faces, other non-manifolds?

No change in the look of it. so far.

You mean, under selection options, select non-manifolds, selects some faces - vertices?
If so, you have to fix it.

Wait… what?

Can you show your textures

I’d upload them each here, but they are to big. Hope this screenshot works.