Realtime outlines problem

Hi, i’m quite new in Blender, so please could you help me?
I wanted to do this toon effect:

The problem is i barely understand what the guy means and it’s too chaotic to me. Wanting to know something more i’ve found this guide:


The another problem is that i don’t have this “Render Pipeline Options” in Material overlap, so i can’t turn transparency on (whatever is it supposed to change). Any ideas?

Ok, maybe my post isn’t very clear. Forget the video. How can i turn that option on (marked with red):

? I go to file -> user preferences -> add-ons, but there’s no such option. So where can i enable it?
May there be a possibility i have to add something to node editor to make it be visible?

Same Material tab, “Transparency”. Down, there is “Options” where you can look for a Z Offset parameter if needed.

I don’t quite understand. I meant i don’t had “Render Pipeline Options” visible at all, nowhere! It isn’t actual already. I needed to check “use nodes” for material. Then those options became visible.

Ok, then i misunderstood the question. UI changes ‘on the fly’ can be confusing.