Realtime preview with Viewport Shading ON locks, crashes and slows Blender down

I have started doing lighting in Blender and I’m finding it painful. The whole thing is not very responsive and if I use Viewport Shading, which I pretty much must, to see any lighting changes, Blender comes down to its knees. I’m using Cycles.

Just using Viewport Shading at all, slows the whole UI down. Basically here are the problems I’m having:

  1. With Viewport Shading ON, I can’t click on things one after the other. I click off a light, and it will take several seconds to update and show the light as off, so I can click on the next thing. Sometimes it will crash if I try to click too fast when Viewport Shading is ON. Actually with Viewport Shading ON the whole UI slows down.
  2. So Viewport Shading is troublesome, as if I try to move it around, it goes all pixelated and once you take the hands off the mouse, it takes several seconds to update the view. I’m not sure if it is supposed to be this way. But then it can’t be used to judge minute and small light adjustments.
  3. If I hit F12 for a frame render it gets stuck for several seconds on 96-99%. I timed it to 40 secs. For a project. And during this time the CPU is maxed out at 100%! GPU is at 4%.
  4. Takes ages to do anything. If I hit F12 and then hit cancel it takes ages to cancel. If I hit bake and then cancel, it takes ages and most times it will freeze. So I must force quit Blender.

I thought it could be my hardware. But it seems to be in between the Recommended and the Optimal requirements for Blender.

Blender requirements:

Recommended

  • 64-bit quad core CPU
  • 16 GB RAM
  • Full HD display
  • Three button mouse or pen+tablet
  • Graphics card with 4 GB RAM

Optimal

  • 64-bit eight core CPU
  • 32 GB RAM
  • Full HD displays
  • Three button mouse and pen+tablet
  • Graphics card with +12 GB RAM

My system:

Intel i5-8400 2.80Ghz
16GB RAM
Nvidia Geforce RTX 2070 Super

I have set it to use GPU in the Cycles render tab as well as in Preferences under CUDA. There only the GPU is checked. Not the CPU. But yet when rendering frames (F12) or baking lighting, the CPU spikes to 100%!

So is it supposed to be like this? Or despite my system being above the recommended it is still not fast enough?

Or am I overlooking some setting?

Is F12 render and baking supposed to use the CPU even when GPU is specified?

Any help is greatly appreciated.

Thanks in advance!

When you say “Viewport Shading” I assume you mean “Material Preview”. Viewport shading can be either “Wireframe”, “solid”, “material preivew” or “rendered”.

If your scene is large this is expected bahvior.
If your scene is small then there is something wrong.

BTW, you have an RTX card, so it makes sense to switch to OPTIX in the preferences instead of CUDA.

The CPU spiking is because Blender has to shovel the render data to Cycles which happens (at least partially) on the CPU.

Do you have complex procedural textures in your scene? I have noticed that EEVEE ( Material Preview is EEVEE even when the renderer is set to Cycles) is very slow if you have procedurals in your scene. If that is the case it makes more sense to use “rendered” mode in combination with Optix and viewport denoing (also optix).

1 Like

Hi.

Thanks for replying.

Yes, I meant rendered view. Well, the last button to the right. Rendered is the only way to see the lighting, that I know of.

I just checked and OPTIX is checked and so is Cuda. Even though I didn’t check OPTIX

The scene is a human model with a texture set to principled BSDF and a few lights.

It seems not matter what, Blender is not using the GPU. I tested the same scene in a friend’s computer, and his Blender uses the GPU. He is using 2.82 and I am using 2.91. And now updated to 2.92. neither uses the GPU. Is there a bug in 2.9x or is it in my system?

Maybe you should take a look at your drivers, who knows?
Also, a few screens may tell more than a hundred words.
AFAIK you can’t have cuda AND optix enabled

1 Like

Have you tried with a different scene?
Just start a new Blender set cycles to gpu and add a couple of monkeys. Just to see if it is related to the scene.

1 Like

I can’t have cuda and optix enabled, as in Blender won’t allow to have both clicked at same time, or if I click both at the same time it will misbehave? Because both are definitely clicked on my preferences. :wink:

Yes, I tried several projects. It’s the same no matter the project.

But I may have found a possible cause. Is there a bug in 2.9x where it can’t use the GPU for rendering/baking?

Because I installed old 2.82 and it behaves differently. 2.82 seems to use the GPU where 2.92 basically uses only the CPU. This is the performance for baking the very same texture in the very same scene:

Is there a bug or is this something with my system?

P.S. Unrelated, but does denoise work for baking with Cycles?

If you click the optix button then cuda is disabled and vice versa.

Rendering with GPU works fine with 2.9x here. So there appears to be a problem with your machine.
In the Task Manager in the GPU panel try setting the drop down from “Copy” to “Cuda” and check if there is still nothing when rendering.

1 Like

Doesn’t seem to make a difference:

So I guess I should start looking for something in my system. Any ideas what could be causing this? Does the performance in the 2.82 capture seem normal?

Try new builds, since 2.92 is still in alpha.
And pay attention to my earlier advice: make sure you got latest drivers

1 Like

How is this possible? you should have either this:
image
or this:
image

But you practically can’t have this:
image
since those are radio buttons: only one can be active

1 Like

The drivers are all up to date. It was the same behavior in 2.91. This is why I tried to 2.92. :wink:

I have now reverted to 2.91

Ok. I didn’t think the blue top part was the button. I thought this was just the tab and you had to click that to select the tab and then manually tick the box in that tab. If that’s a button and not a tab, then yes, only one at a time. :slight_smile:

It would also explain why when I click on both “tabs”, the boxes are already ticked. This was what made me think both were activated at the same time.

maybe I should try to bake with optix activate then to see. But ti doesn’t make sense it wouldn’t use the GPU anyhow.

Update: The optix experiment didn’t work, as the bake tab under cycles then disappears. Apparently baking with optix is not possible.

But why is 2.91 not using the GPU in my system? Any ideas of probable causes, when it works just fine in 2.82?

Thanks again.

It’s getting more and more into the Twilight Zone :wink:
Try investigating the Nvidia Control Panel, 3d settings. Is it preventing apps to access the 3d acceleration? 2.82 might be an exception in there…

1 Like

Why Twilight Zone? :slight_smile:

Under which tab do you mean in 3D settings in the nvidia control panel?

Thanks.

I mean ‘Mystery’ and uncertainty…

And here I mean your operating system Nvidia control panel, not in Blender

1 Like

Yes. But I checked the control panel and didn’t find where an exception for 2.82 could be or where to check if 2.91 is excluded. :wink:

Well, at this point I can’t think of other variables. You can submit a bug report, specifing system specs. And possibly attaching your files. So that devs can (possibly) reproduce your pc behaviour.

1 Like

Thanks. But could you describe where in the Nvidia control panel I would possibly find if it is preventing apps to access the 3d acceleration for 2.91?