realtime text bug: @@@@@

my problem is same as this:

so from the link:
“I use real-time text in my game. Recently, the text began to show only @ symbols instead of letters. It would still figure out the right number of characters in the word, but the characters would all be @ symbols. I was tipped off that it had something to do with packing images. By unpacking all my image files and re-downloading the font image,”

The problem is not the font file, it is good, because restarting the scene the texts is okay. But using Blenderplayer it is not possible to restart the scene. So my main menu contains only @@@@@…

Please help…

It is to do with packing images. Unpack the textures, and try replacing or opening another copy of the original file. It’s a problem with blender i think

use blf or bgui for realtime text( uses .ttf fonts to display text) instead of the old method.

I think I solved this but I need some tests…
I will back. :slight_smile:

So I think the problem is:
-if you have a text mode face without assigning a texture on it, or
-if you have a text mode face with non-font texture
Your other texts may be wrong in BGE.

So this is solved.