realtime tracking problem


(d52477001) #1

hi,

ok… say i have my character which has to go to a specific point. now i want an arrow to be in front of the character and point straight at this point so that the player knows in which direction to go. How do i accomplish this?

I tried making an arrow, parenting it to the character and making a ‘track-to’ logic brick (tracking to an empty) but this doesnt work. it works at the begining and when the character just moves forwards and backwards, but as soon as the character turns the whole tracking is messed up. it doesn’t point to the empty anymore and when the character turns the arrow starts spinning like crazy. is there any way how i can solve this?

thanks a lot

d52477001.

BTW you will soon see my the first part of very first game posted here. it is a kind of a puzzle game.


(blendedHKU) #2

I assume you parented the arrow directly to the armature.

Then you get the strange things when you turn.

Try this.

Parent your whole armature to an empty, then use this empty to put the ‘move’ actuators (forces) on (so you rotate and move the empty when the character turns,moves).

Parent the arrow to this empty, and it should work, just as you describe with the track-to sensor.


(Yamyam) #3

Do you want to make like a compass for navigation?

You can use Vertex Parent([Ctrl]+[p] in editmode) between arrow object to mesh of Character(or object operated from player).


(lizard809) #4

thanks yamyam never knew this trick


(d52477001) #5

sorry for the very sloooow reply but my modem got hit by lightning… :frowning:

anyways… thanks fot yout replies.

Yamyam: is it possible to do this in an overlay scene so that it looks like a real compass like some times done in fps games?

d52477001


(lizard809) #6

heres a file i made with a compass on an overlay scene, feel free to use the scripts

http://mysite.iptic.com/cluh/compass.blend


(d52477001) #7

lizard809: hmm, the link doesn’t seem to be working…

yamyam: nope, sorry doesn’t work. the arrow points in a different direction but i still have th same problem.

blendedHKU: my character is just a simple sphere and i parented the object to that.


(lizard809) #8

i guess iptic is down right now, check back later

!!now its up!!


(d52477001) #9

ok great :smiley:

thanks


(Yamyam) #10

Sorry for the very slooooooow reply too. Your problem looks like solved…

And thank you lizard809 for your sample.:slight_smile: