Receiving shadow, but not casting on itself


(Tekergo) #1

Hi everyone!

I’m making a VFX video, and i have to put CG stuff on a real world footage. Not a big deal.
But the problem is, that stuff needs to be in a corner, and if i want to get the shadow pass from the 3d-environment, the walls cast shadow on themselves too. How can i separate them from each other, while letting the main object casting shadow on the ground and the wall as well?

I also tried the new shadow catcher option, and it’s quite good, but unbelievably slow. That’s why i thought it’d be better to use regular surfaces.

Do you have any ideas?


(animelix) #2

You could disable the casting shadows funktion for the walls/corner



(Tekergo) #3

With a little more tricks in addition, it works. Thank you, sir!