Recieve Shadows Only

I’m currently having a problem with an effects shot I’m working on. I’m trying to put a virtual object into a 3d scene. I made a quick mock-up of the scene in blender so the fake object will cast shadows correctly on the real objects. The problem I’m having is the mock-up is casting shadows on itself which is leading to some very strange results.

Is there a way to make it so a material will recieve shadows only?

AHA! I just had to enable the ‘layer’ option for the lights (which are on layer 1), and move the mock-up to layer 2. It works perfectly now!