"Record Animation" deleting key frames when I hit the "p" key

Hi there,

I’m doing a glass shatter effect wherein a body is thrown through a plane of glass. And using tutorials and help from here, I got it working. At least, the simulation portion of it, that is.

What is suddenly not working is the “Record animation” portion of it. Here’s what my scene’s composed of:

A plane of glass to be shattered
A low res proxy for the body that will fall through it
And an “activator mesh” that sets the glass in motion only when the mesh touches the glass. Or rather wherever the material of the activator mesh touches the glass. So this mesh sorta moves with the proxy.

So far, it worked. But when I try to record the animation AND hit the “p” key for simulation, the activator mesh stops moving. And so, the glass never shatters.

On trying to fix this, I found that when I hit the “p” key, all the keyframes of the activator mesh sorta disappear. And are replaced by something else that is causing the mesh to stay still.

I’ve a feeling I’m missing something again. Any help would be very much appreciated!

I’m attaching the blend file as well.


glassBreak.blend (620 KB)

Before you record the physics
Select the ‘Sphere’ object.
Go into the graph editor and lock its animation channels (padlock icon) so they don’t get overriden
Then record the animation


glassBreak.blend (1.72 MB)

Thanks, Richard! It worked :slight_smile: