RecordMyDesktop problem - Care to help?

The reason I say that is very simple. Whenever I use RecordMyDesktop, (the only recording software that works on my computer) it slows everything down so much that I can’t do anything. It’s very useless.

I always hear about people being so HAPPY with recordmydesktop, but I don’t get it. My videos are always slow and choppy, full of mistakes, and if I’m recording blender, nothing refreshes.


Little help, please?

It works almost fine for me on Ubuntu 8.04 + Compiz Fusion. What distro are you running it on? what video card are you using?


Your thread title “sux” too!
RecordMyDesktop works very well to me, even with a quite old comp ( Athlon 64x2 / Gfx7500).

not used it in a while, but it has settings for what and how it records… maybe try tweaking some? see if it performs better?

Ubuntu, (Radeon HD 4550 ATI graphics card).

Oh, and I realise that the thread title is a little derogatory, but I can’t seem to edit it. If there’s going to be hard feelings, could a MOD please nice it up a little?



Well, your title its not fair with the program developers, that’s all!
Instead you could tell us what are you trying to “record” and how ( some settings, maybe)!

Thanks OTO! :smiley:

My system specs are:

  • E5200 processor (Intel)
  • 8500GT (nVidia)
  • DG35EC motherboard (Intel).

I’ve had two problems with recordmyDesktop:

  • Not recording audio from a headset. Fixed it after quite some time of messing around and finding the right device id (hw:0:0, iirc) and setting the mode to mono.
  • The recorded image got frozen sometimes. It can be fixed by using an effect like zoom while you record. If Amarok is running it can also cause some problems, so it’s better to close it when recording.

The only real complaint I have as of now is that I haven’t been able to find any decent video editor to edit .ogv files, so I can not do simple corrections or even add credits/title. Transcoding the video hasn’t helped at all, since the quality degrades too much.

BTW, I use the gtkRecordmyDesktop frontend, it’s very easy to use and it has full support for the switches the command line version supports.


Me too, I use the GTK frontend , nice and easy to use!
And I complaint about the OGV only, too! :wink:
What I do is to record at a big screen size ( if possible) at 100 quality, then convert to AVI with Mencoder and Edit with AviDemux!
Give it a try?!

Yeah, I have tried recording at 800x600, 100% quality and then transcoding with mencoder, but image quality degrades too much :frowning:

What transcoding settings do you use?


I don’t really have a problem with the image quality, I’ve found ways around that. I’m more concerned about the performance drop I get when I’m recording. It gets so slow I can’t even function.

PS: You say I need full shots enabled to record blender? I think I tried that, it still didn’t really work out.

In my case, I just set the screen resolution at 800x600 and use fullscreen recording. In my PC I can use quite comfortably the program (simple scenes).

You say you’ve found “ways around that”… do you mean you can edit the video and get a good image quality after the editing?


Yeah, the quality of a rendered video in the sequencer actually goes down as you play with blender. So set up the sequencer, and then reboot. IMMEDIATELY render the .ogv as an .avi, without adjusting any settings. You’ll keep the quality quite nice, actually.

How do I get performance back when capturing with RecordMyDesktop? It gets so slow that my videos end up boring, and I’m frustrated trying to do anything of value.

Guys? I still need help with this. My videos are very slow, and when recording blender they are also very blurry and bits of the screen are messed up.

Please help me?

What can I say?
Is your graphics card working well…I mean, with “accelerated drivers”?
Maybe there’ some “services/programs” that slow down the process?
My comp is an “old” Athlon 64x2 / Gfx7500?
What about you?
Here’s an example of what I’ve recorded in 1280x1024’ ( the original one):


That’s light years ahead of what I can record. The outputs of my recordings in blender are like, 3 frames per second, and they’re not updating the whole screen. I get a weird blur of different frames.


I’m pretty sure my card is working well, I just set the vertical refresh rate to sync better with the monitor.
I’m also on an Athlon 64x2, “old”, I guess you might say.
I’m on an ATI Radeon HD 4550 Sapphire.

Hope this helps.

it’s your radeon display (graphics card) driver, i would bet dollars to donuts. I got one, and i cant use Blender on it cuz of the sucky opengl drivers. try using the nvidia driver, or the non-proprietary driver.

Where do I find these drivers? My computer only lets me see one option for my card…

I think it’s worth to wake up this old thread since I found a very useful tutorial that shows how to use ffmpeg to produce high-quality screencasts.

I also found (after much testing) that some artifacts that appeared on my recordings were caused by the nVidia driver having enabled the “OpenGL flip” option.

Hope it helps someone!