Recreating a Round Tower

I’m trying to recreate a tower from this reference image:

The biggest problems that I solved was the shape of the windows and arches and how to unwrap that kind of object, also I added a little detail to certain parts but questions always pop out for me on this one.

I guess you can call it a great learning opportunity because I can apply on it so many things I need to learn about from baking to sculpting…it’s very interesting and fun, I hope I can get feedback on this asap.

Here are some of the questions regarding this.

  1. Why is the shading on the model so “wrong” without the edge split modifier applied (with checked normals), is it because the mesh lacks geometry ?

  1. After applying the edge split modifer it splits the mesh in bits and pieces, I know how the modifier works but is there a way to prevent this, or let me reformulate, is there a BETTER way of doing this without even needing the edge split modifier?

  2. This thing would be a pain to texture in gimp to make it look exactly like the reference image and it’s a great opportunity to sculpt on it to add those creases and indents in the wall where the windows are. How can I start sculpting on this model without the subdivions rounding stuff out like my windows etc ? What am I doing wrong?

  3. How to make a certain thing/piece on your mesh look smoother than the rest of your mesh except adding a bevel to it by hand or addon (even in that case it doesn’t look that smooth, like what you get when using the subdivision modifier) ?

Thank you for even reading all of this nonsense, I hope someone can help quench this thirst for knowledge.

Also, here is the blend file if you are interested:
tower.blend (475 KB)

i will see what i can answer…the shading is wrong because you are applying phong (smooth) shading to a not-smooth object. this is inherent in the algorithm, there is no way around it other than what you are already doing. There is no way around using the edge split modifier either (at least to the best of my knowledge), but i dont see why you need to apply it before you are complete.

Thanks for answering!

You are right, I don’t need to apply it but sculpting doesn’t support it, I guess the answer is to disable it and enable it back after I’m done but what If I decide to use the mesh for something else, how would I handle a mesh that needs to look smooth but is in pieces? Removing doubles would only bring me back to the start.

I want to be able to sculpt those details in the tower where the windows are and use a texture for the tower. I think at least that would work but first I need to get it in shape so I can even begin sculpting on it. I don’t know where to start and I’m confused on how to approach this.

“not supported in sculpt mode” means that the modifier will not be applied ONLY WHILE YOU ARE IN THAT MODE. the mesh will shade strangely while you are sculpting but once you switch back to object mode, edit mode, etc. it will be look fine. just ignore that warning it shouldnt cause trouble at render time. but i really dont know much about sculpting so i cant help you there though…

however from the little i do know about sculpting, i know you will need a lot more vertices in your mesh for it to be effective. what i think you need to do is start over with a lot more vertices along the cylinder (128 should do nicely). cut out your windows, and then add edge loops and edge weights. see attached file for how to do the last two steps…

Attachments

tower.blend (534 KB)

OK,your problem with the multyresulution is probably nothing big.



Make sure to set Preview to the same subdivision level as the other settings:)
Hmm,I am not quite sure what the problem with the smooth shading in sculpt mode is…I never had a problem with that.Maybe you can give me your current .blend file and I can see if I get the same problem.
The problem with rotating/moving on the local/world axis also seems to be taken car of quickly :wink:
When you have your model selected press “R” or “G” to rotate/move and press e.g. “Y” ones to rotate/move on the global axis,press twice to rotate/move on the local axis.

Thanks, that was a foolish mistake. I didn’t pay attention when I was in sculpt mode. That works like normal but the flat shading happens when I turn it to simple and I need simple to not make things round.

If you want the blend file it’s attached in the first post :slight_smile:

I tried also the shading trick you mentioned before but it looks weird, the mesh shading (without edge split) looks a little bit better when I add some extra edge loops to support it.

The local axis for the pipe seems not to work, is it because I applied the rotation to it before? Is there a way to fix it? I tried the local thing with another object and it works like a charm, thanks.

OK,I looked at your .blend file and play a little with it.
First of all I deleted the inner part of the Tower as I didn’t see a need for it.It only takes away lots of precessing power of the PC when you use a multyres modifier.And then I replaced your Pipe so it dos not behave that strange when you rotate/move it.I guss you applied rotation?And then a UV maped it because I think it would be batter to use a displacement map made in photoshp/gimp.Below is the .blend file.You still have to delete some verticals inside that I didn’t see if you want to make it proper.I hope you know how to make/ apply a displacement map?
Hope this helps
tower.blend (1.58 MB)

Please note that I am only using blender for 4 month and may not know every thing.So this is only the way I would try it.

Thanks for optimizing it!

Can you explain the process with the discplamenet map and for what purpose? I have to admit that that’s the one thing I’m lacking most knowledge of.

edit: the texture for the brick trick is amazing (so much faster than what I had in mind)! Unfortunately the blend was not packed so I had to pull my own texture to play with. I totally forgot about this amazing feature.

OK,a displacement map is a Height map( if you know what that is).So Lat’s say you have a plane that is flat and you want to make it look like a part of a brick wall.Than you first have to make a Image in photoshop/gimp that is black and white. The seems of the brick wall would have to be black and the bricks tham self would have to be white (lack= the mesh dose not get moved,white=the mesh gets moved out as much es possible,anything between black and white(gray) gets moved depending on how dark or light it is).When you have made the displacement map(image) you can go in blender and du following:
Option 1:Click your plane,ad a new material,now ad a new texture,click on image or movie,open your displacement map,go to influence>Defuse and disable coller,now under Influence>Geometry enable displacement(the option at the bottom).Now you can go to the add modifier tab and add a multyresulution,subdivide 8 times or so(this is up to you how much detail your mesh should get).Now you are done and can render your plane.To adjust the strength of the displacement map go to Texture>Influence>Displacement and set the strength to what ever you prefer:)

Option 2:Select your Plane,add a multyresulution modifier,add a displace modifier,in the displace modifier open the displacement map.Now you instantly see the result.You can adjust the strength in the Modifier.

Ifyou need to I can gmake a .blend file as a demo.

Hope this helps:)

Thanks for the clear instructions.

Why do you prefer a displacement map over a normal map? Is there an advantage? Can you bake to a displacement map?

The big deference is that the normal map dose not modify the mesh and can’t be made manually(as far as I know),while a displacement map dose modify the mesh and can be made manually (in Photoshop/gimp).So what you can do is make a displacement map,then sculpt in detail and than you can bake a normal map on a low poly model.The advantage in the displacement map is that if you look at your model from a low angel you can see that it is 3d,but the dis advantage is that you have a longer rendering time and a lower frame rate in your preview window.The normal map is exactly the opposite if you know what I mean;)

I think I understand but how am I supposed to make a displacement map for my case?

Maybe we don’t understand each other very well, by DISPLACEMENT do you mean the texture that you use to sculpt because you mention it in your last post. If it’s not too hard please make an example and if you use any texture please pack it.

OK I will do an example,but probably not before tomorrow morning.

Thanks! I tried looking for tutorials online but there are none, just general. I’ll play with sculpting in the meantime.

OK,I remade the tower because my last optimizing (the one I gave you) damaged the outer hull.So don’t us my last .blend file!
I now deleted the inner part of the tower and also edited some loop cuts so that most quads are almost square(I did that for the multyres add on).
Than i also made a UV unwrap (I hope you no something about UV mapping?).Then I exported the UV map and made a Displacement map according to the UV’s.Then opened the texture under Tower>material>Texture and disabled all influence.After that I went over to the modifier tab and added a multy res(I could only subdivide a couple of times because my PC dose not like the tower and alrady gets lagy when it only has 250 000 faces.Normally I can get it to 6 mill even so my pc is a oald laptop) and then a displacement modifier.In the displacement modifier I opened the image and put the strength to a very small NEGATIVE number.After that I went over to the texture>brush and made a new cloud texture.And then at last went in sculpt mode and opend the new created cloud texture in the pant brush,ant just added some bumpiness.

HERE IS THE FIELE:http://www.2shared.com/file/UjeWjpiY/Tower.html

So that’s how you do it! Brilliant! Thanks.

Can you bake this to a lower version and how?

I assume it’s not render friendly with all that subdivions. I want to bake that and the normal map from the sculpting if it’s possible? How can I combine it?

Hey sorry for my late reply.
So what I would do is following: Duplicate the Tower and don’t move it after duplication,remove the multyres modifier and the displacement modifier.
And than just bake it.
Maybe you have to apply the modifiers before baking.

If you have any more questions,just ask. xD

Thanks for the amazing help. I will try it out now and let you know how it went.

I can’t seem to be able to bake the displacement map normally. When I bake it out it’s all grey. Here are my steps.

  1. Unwrap mesh
  2. Copy mesh and move it to new layer
  3. Apply all modifers to the high res mesh
  4. Delete the modifers from the low poly mesh
  5. Make a new image for the low poly mesh (2048x2048)
  6. Select the high res mesh first and then the low res mesh
  7. Pick Displacement from the Bake menu
  8. Check the “from selected to active box”
  9. BAKE
  10. Save the image
  11. Give the low res mesh the displacement map under textures, turn off color, turn on displacement
  12. Give the low res mesh a subdivision modifier

Nothing happens. Help please :smiley:

OK here might be your problem :You don’t want to bake a displacement map,but rather a normal map.
And also note that you have to also have to change the Bake mod from Full Render to Normals.
All your other steps seem to be right accept of that it might not work when your models are on two different layers,but that I don"t know.