Recreating Maya Ad > Help w/ particle rotation + material


I have been working on this little project for the last few weeks in my spare time. I’m trying to recreate the image in this Maya 6 ad in Computer Arts magazine. I am having trouble with the ring of particles. I have made the ring but the orientaion of the cubes isn’t right. I’ve searched this forum and and looked through the manual. I did the duplivert tutorial and creating a ring with a cube as its child, turning on dupliverts and messing with the track_ and up_ buttons gets the exact result I want, however, the moment you put a Particle effect on the parent ring, the orientation effect is wrecked. The Vect, Track_, and Up_ buttons don’t fix it. I have the ring parented to another ring (path for animation) and the ring follows the path fine and I have it on frame 180 which forms the complete particle ring I want, but I need the cubes to face out on the emitter’s vertex normals. Can this even be done?
Here is a close up of the particle ring from the Maya image and below is a screen from my scene file:

I have a question about the materials I’m working on for the twisty bands but I’m not sure if I should post it in this thread or start a new one in the General forum.


I have been trying to get this to work almost all freaking day and evening. I am convinced that this cannot be done in blender without modeling the whole thing by hand. I took a crack at it in Cinema 4D XL6 and was able to pull it off with a little thinking and some tweaking. I have tried the same approach I ended up using in C4D in blender and it STILL wouldn’t work. The particle system isn’t very flexible apparently. I tried adding TrackTo constraints on the dupli’d objects, still no go. Here’s a picture of what I did in Cinema. I ended up exporting a section of this to .obj and i’m going to try and build the effect in blender.

If anyone else can come up with a way to create this “particle tunnel” I’d like to see it.


When you pressed the Vect button in the particles, did you recalc them?

Because I just did it, and turned the vect button in the particle options and it oriented to cubes in the direction of travel.


I tried pressing Recalc each time I changed a Track_ or Up_ button. All the Vect button seems to do is give the particles random orientations. It doesn’t seem like the Recalc button does anything regardless of what settings I change before pressing it. I wanted the particles to face the direction of travel AND have them rotated locally to have each particle’s local axis (for example, X) pointing toward the center of the tube, NOT the center of the ring. If you look closely at the picture of the Maya ad, and the individual particles’ orientations you should see what I am trying to achieve.


Hi, I have tried what you said quickly in a scene and here’s the result I get no matter what Track_ or Up_ settings I change on the dupli and Recalc. Vect button is on. here’s a screen and below is a link to the blend file.



The rotation is crazy i think the particle system is not done to calculate rotation when a followpath is moving it. possible bug.
For now there is always the Lattice to do the job.

Sorry, I didn’t realize you were making the emiter move. I was using a vortex force feild to curve the particles.

Another option you could try is to make a circular tube and use dupliverts. To make them a bit more random, you could use the random selection tool and the rotate and scale them about the centre of the circular tube.

A bit more time intensive, but I think it will give you what you are looking for.


I just tried this, and it doesn’t work right. I can’t get the dupliverts to align properly on a circular tube. I don’t understand why.



Ok, I just make something quickly, by adding a mesh circle, copying the vertices and moving them and scaling them a couple of times to get a tube shape, and then used the dupliverts and Rot and Track buttons. (You have to turn on Rot for the parent object, but adjust the Track X, Y etc for the child object.)

This may not be exactly what you are looking for, but it may work.

Actually, the problem is not with FollowPath (and its interaction with the particles) and neither is it really a bug. When using Vect particles, the orientation vector is derived from the motion of the particles. In your case, that motion is null. Your particles are motionless, so the orientation vector is screwy.

A quick and simple fix is to add a slight Norm force to orient the particles with the emition plane. A value of 0.001 will suffice.


thanks theeth, I added a norm value of .001 and it aligned the particles to the direction of travel. Now, I have another 2 questions:

  1. Is there a way to ‘bake’ the particles at a specific frame? This way, (the method I used in C4D) I can take that particle ring and use it as the dupli object in another emmiter, thus creating the full particle ring effect.
  2. Is there a way to make the particles face the center of the tube while maintaining the direction of travel? I have a screen grab below illustrating a cross-section of what the final particle ring whould look like:


right. too simple to be seen.
Gonna know next time

  1. Ctrl-Shift-A on the emitter.
  2. None that I can quickly think of.