Recursive beveling in Bevel Center broken?

Hello folks!

I’ve been using the wonderful Bevel Center script since a while now. It’s really amazing how a few beveled edges can make objects look much better in the render.

So far I never used the recursive beveling feature. But now I’d like to have a curved bevel so I tried it. However, I get a Python error when doing it.

Here’s how to recreate the error.

With the default cube in an otherwise empty scene, tabbed into edit mode and selected all edges in edges mode, I opened the script in a text window.

It says that it is version 2.0. Should be the one that came with Blender 2.42 as far as I know. I use Python 2.4 by the way. On Windows as well as Linux.

When I run the script, I get the UI and press “Bevel” with the standard settings. The script works well up to here and bevels the edges for one step.

When I press “recursive” now, I get the Python error message and see this on the console:

Traceback (most recent call last):
File “”, line 368, in bevent
File “”, line 447, in recursive
File “”, line 397, in bevel
File “”, line 191, in make_faces
TypeError: unsupported operand type(s) for -: ‘tuple’ and ‘int’

Somebody got any idea what’s going wrong?

Thanks a lot in advance!

See ya,