redhat 7.3 issues


(kattkieru) #1

Hi all,

I was blendering under Mac OS X and Windows XP, but decided to download the redhat distro at work and install it. Everything seems to work, except hardware acceleration. It’s very strange. The installer recognized and configured my GeForce2 GTS/32 just fine, but when I run OpenGL proggies like Blender I either get a really crappy framerate or, as is the case in Blender, the program will update the screen quickly for a few frames, halt, and repeat.

Anybody have a similar problem with NVIDIA cards and redhat/Blender? I tried updating my kernel and XF86 drivers from the Nvidia site, but the RPM’s screwed X up so badly I had to format and reinstall.

I don’t want to be stuck in a Win32 world! :o

Thanks,

  • Charles

(rwenzlaff) #2

The redhat distro comes with the opensource driver for the gforce (“nv”). Nvidia won’t let anyone know the dirty little secrets of what’s going on inside their card, so the OpenSource driver has really crappy acceleration.

You can download a closed source driver from nvidia.com (“nvidia”). They have rpm’s for RH7.3. You need to get the GLX module and the kernel module. The GLX is generic, but you need to select the kernel module compiled against your kernel. If you’re not sure there’s an nvchooser program that will tell you what to D/L.

(You won’t be able to redistribute your system because loading the closed source module taints the kernel - which is why RH & everyone comes with the OpenSource driver. But I doubt you care…)

There’s about 3 changes that need to be made in the /etc/X11/XF86Config-4 file. There’s 1 that goes in the modules.conf file, but the RPM’s do that one for you. Read the README file, it tells you. Make sure you know how to boot to text mode before installing, just incase something goes wrong (best bet is to boot to text, install, try to start X).

There are a few chipsets/processor combos that still cause problems for the driver. The 2960 release on my Athlon and Via KT133 MB was locking up regularly for me. I’m testing the 3123 now. So far so good but it only happened 2-3 times a week before I’m only on hour 6.

Bob


(PowerMacG4) #3

What window manager you are using?
My redhat 7.3 laptop sucked when I use KDE or Gnome. I usually use a plain window manager like Blackbox or better yet Failsafe. With failsafe Blender should rock. Blackbox should give you some real good performance also try xfce or fvwm.


(kattkieru) #4

Thanks for the help guys!

Actually, I ended up having to build the modules by hand and install the files built by hand. The RPM’s, for whatever reason, installed the drivers and put files in strange places where the kernel either couldn’t find them or thought they were corrupt. Yeah, I’ve never seen that happen before either. I remember now why I hated Red Hat when I tried it years ago… But it’s the only system for download for free that has KDE3. I like SuSE, but I’m not paying for Linux. :smiley:

On a side note, once I got everything fixed and got my runlevel recognized (I’d edit a file and it’d get changed back!), now everything runs beautifully and Blender positvely screams. It’s insane how much faster it runs under linux as compared to WinXP on the same machine. I’m probably getting double the framerate on complex scenes.