Reflected light problem

Hi guys! I’m working on a scene, far, far away to be ready but trying putting a light to se how the work it’s goin on I saw that my light was reflected in the mirror, I tried to deactivate the glossy in the ray visibility of the light but if I do that i loose all the glossyness on the wall and the rest, what can i do?

Hey Giakkons,
there might be an easier way , but I found that you can do this via renderlayers. You can put the emission plane on a single layer in the scene and the mirror on it’s own layer as well.

Then you can add a new renderlayer to the scene with only the mirror as the rendered layer and the layer with the emission plane excluded from that. The “basic” render layer can contain the layer with the emission plane but should of course mask out the mirror.

So…the “basic” rederlayer gets all information except for the mirror - the “mirror” renderlayer gets influenced by all layers but the one with the emission plane. Hope this works for you!

Select the light object go to object settings - Ray visibility and deselect glossy.

Thanks a lot IronLung!