Reflection broken? (0.2.4)


Is the reflection broken in 0.2.4?

i set the refection trough the material/texture panel, the ground show reflection of the object above (this works) but the object getting reflected stops rendering, i mean top face won’t render or if i move it slightly up then the whole object disappears. also seems that the position of the 3dview camera matters.

very strange. here is a blend.
play it, cube disappear, reflection is shown. look trough camera everything disappears

reflection doing strange things.blend (521.4 KB)

Maybe your Vcard is damaged?

I checked your file, and as far as I can see everything is ok :thinking:

UPBGE started in perspective view, and in camera view (not sown in GIF) and it seem to work OK.

hmm, maybe because i use amd card? Card itself is not broken.

This is what i see:

@Cotaks - have you tried any of the 23a_ branches?

there were some bad commits that made it into 0.2.4 (scengraph refactor and some other stuff)

does it work in 0.2.3 for you?

no, is there a windows build of it?

No same problem

23a attachments does reflections. Also quite stable; I built all my nasty open world stuff on it.
EDIT: updated link.

No clue what to do with it xD
No .exe included.

Weird. Either Mega messed with my files (unlikely) or I had too much to drink.
Uploaded it again and triple-checked everything was included in the rar. Should be good now.

1 Like

Same issue as with the other versions, only the reflection will show up :cry:

@aWeirdOwl @lordloki_reloaded

Do you guys have an idea how to fix this?

I can get it to work 23_attachments :thinking:

that’s weird…

I didn’t say that it didn’t work, it’s just the same result for me as in all other upbge version (like my screenshots).

1 Like

Have you tried updating your graphics card drivers?

yup, with ddu. older or newer doesn’t matter.

I followed this Guide: []
It works, but everything above the reflecting Face disappear.

Edit …
I runned the default Win 10 Driver for my AMD Card, and got this Problems. After an Update with AMD Drivers, UpBGE works great again. :heart_eyes: No more issues with Reflections.

hmm what driver version are you using? And does the blend i provided work as well?

Yes, it seems the blend works great.
I run the actual AMD Adrenalin Driver Software 20.2.1 now.

This is nice, didn’t expect to be a driver problem, but it’s working now!