Reflections with sphere maps

Hi,

I just struggling with the following task. I have a model of a building with a lot of window plates which should be reflecting some fictive buildings around. The texture for the reflections is stored as a sphere map. The resulting image should have a solid white background. The environment map should not influence the scene lighting at all. Is there any option to use the world node for the environment map while keeping the white background? I would like to avoid compositing as I will have to use it heavily for other stuff.

So far, I have achieved to use a large sphere to which I map the environment texture. The reflections are rendered perfectly, however the geometry of the sphere blocks the sun lamp. Thus, the scene gets rendered with ambient occlusion only. Is there a way to let the rays of the internal blender renderer to pass the sphere from the outside and to hit it from inside? Basically I just need to flip the orientation of the triangles for the sphere. A solution with different layers is also no option for me as I will need them for blending-in parts of the building in an animation.

Thanks for any suggestions :slight_smile:

In the material panel, with the sphere selected, go to the ‘Shadow’ subpanel and turn ‘cast’ off.
that will disable the casting shadows for the sphere, but still render the sphere.

Which option do you mean exactly? Cast Buffer Shadows or Cast Approximate? Neither works for me. I have done two tests. In the first one, I used the original sphere that is so large everything else in the scene fits inside. In the second one I made a small copy of it and placed it over the roof of the building. Both the big and the small one continued to cast raytraced shadows even when everything in the shadows panel was turned off.


I was only able to disable the shadows (while still seeing the geometry of the spheres) by disabling the Traceable option in the options panel. However it result of that the nice reflections on the windows disappeared as well. So I’m searching for some kind of an alternative solution which turns off the shadows but not the reflections…

Try replacing the Sun with a Hemi light, which will pass through objects (won’t work in Cycles)

At last, I solved it by cutting away the top of the sphere, so that the light may come in. It would be a nice feature for future releases, to be able to mark a material to appear in reflections only.