Registry Key for Yafray?

Hi everyone,

I’ve been getting closer to utilising the power of Yafray but I’ve run into a problem that I can’t seem to solve.

I installed Python22 and it all works fine in the console. The Blender scene gets converted but then this message appears on the console:

“Couldn’t FIND registry key for Yafray, is it installed?”

I don’t quite know how this can be because I’ve installed the latest stable version of yafray. It would appear that Blender cannot recognise the installation of Yafray.

I assume that the registry key has something to do with Yafray’s installation but perhaps there is someone who can post a useful definition of what it actually is and how to ensure that Blender finds it.

I’m currently using BF_Blender20040118

My OS is Windows 2000.

I hope someone can help me out



Well, I had the same problem, which was solved by making a “render” folder under yafray folder and then I placed convertr script in there. After that yafray began to work under blender.

Tough there was a whole thread in news&chat about this problem. There is various possibilities.

Hope this helps. :slight_smile:

Still not working. : (

I need something a little more explanitory.

try this:

create a .bat file in your blender directory (where your .exe is)
name it “yafray.bat”
the file would contain the following text

c:\yaf6\yafray.exe %1 %2 %3

(insert your own path values, these are mine)

that’s it

this has solved the problem for me and I just copy that yaftray.bat into each new folder I build for the new cvs builds and it works great!

good luck!

I’ve already tried this several times. It doesn’t work with me. Feels like I’ll never get Yafray to work :frowning:

Thanks anyway

The windows problems never seem to end…
In any case, you are sure the installation worked correctly? I still use win98Se (when I have too, I mostly use Linux now), but there probably is something like ‘regedit’ for win2000 as well. Try running regedit (from the start menu using the run option, I think…) and do a search for yafray, use ctrl-f key and type ‘yafray’, the search may take a while. If you find something, make a note of it, and repeat the search by using the F3 key untill the search is complete. Post here on what you find, if you actually are going to try this.

Another thing you could try is just uninstalling and reinstall again, might work too, who knows…

I did the search in the regedit but it just finds lots of files. I don’t have time to write them all down. Perhaps you could tell me what I’m looking for.

I’ve deinstalled and reinstalled Yafray more times than I can remember. I even deleted the zip file and downloaded it again from thinking it might have been a corrupt file during download.

I’ve tried installing Yafray in the same folder as the Blender.EXE but still nothing works. I’ve set all of the Environment Variables correctly. Blender works fine, even better now I’ve installed Python22. No more import failure errors on the console.

But I still can’t get Yafray to work. I see so many images that have been rendered with Yafray and I find them absolutely amazing. I’ve been using Blender for about five years now so I have a lot of experience with modelling, texturing and animation. I just need a renderer that can deliver. I need a Raytracer. I want it to work so much and it breaks my heart every time I see that same dumb message on the console.

Why can’t Blender see whats standing right in front of it? How can it not find something that’s actually there in the very same directory. :frowning:

There are so many threads in these forums about how great Yafray is and how easy it is to use and install. I don’t get it. What am I doig wrong?

Ok, well, I guess all those files could be things like ‘most recent files’ it finds or something. The exporter looks for one key in HKEY_LOCAL_MACHINE, “Software\YafRay Team\YafRay”, the key name is ‘InstallDir’. But I guess that isn’t there otherwise the exporter would have found it.
Is there anything at all using the yafray name in the ‘software’ list?

I notice you say you`ve installed the “latest stable version” - at the Yafray download page, this is 0.0.4, which Blender can’t use, I think.

If so, delete this version, and try the 0.0.6 version from the front page, under the news story “Updated 0.0.6 pre-released!”.

Thanks for all your feedback. It makes me feel like I’m not alone in this battle.

Well I searched for the file “InstallDir” in the regedit but apparently it doesn’t exist. I think we’re getting closer to the problem. It would seem that for some strange reason, Yafray is failing to install “InstallDir” in the regedit.

What kind of file is it? Can I write one using NotePad and then simply put it in the regedit myself? Is there somewhere I can download the individual components of Yafray?

Anyway, I’ll try with the latest unstable version of Yafray as suggested. I’ll let you know if it works ASAP.

Thanks again for your help

You need 0.0.6, it won’t work otherwise.


YES! I finally got it to work. I downloaded Version 0.0.6 and installed that. Now my blender scenes can be rendered in Yafray. They look great. Especially with the reflection features etc.

Yafray’s Seems to be having a problem finding my textures but that’s not something I’m too worried about.

Thanks guys for all your help and suggestions.

Happy Blending ; )


Well, I am, I thought I solved that… Are you using one of the latest cvs blender builds?
And if so, is Blender located on the same drive as your textures?

I downloaded the latest CVS and it works fine now. I had read many threads on the Yafray Texturing problem before so I wasn’t too concerned anyway.

I’m finding quite difficult getting the lighting right in yafray but after a while tweaking about I’m beginning to discover how it all works. I’ve already started rendering some of my favourite Blender scenes. I’ll post some pics as soon as they’re finished.

Thanks for all your help