Remesh Modifier and Limited Dissolve hangs Blender

Experimenting I have noticed this. If I add the Remesh modifier with a large value of “Octree Depht” and apply the changes then “Limited Dissolve”, Blender hangs and I must kill the process.
How to reproduce the problem:
Add Remesh modifier to the default cube with “Octree Depht” value to 9 and apply the modifier. In edit mode select all and X > Limited Dissolve.
I have noticed that sometimes even Blender hangs just with “Octree Depht” large value without appling de modifier.

I have noticed that there is increased use of RAM, but not enough to exhaust the resources of my PC.

I know it is a large value of “Octree Depht” and there are many vertices. But I want to know if it is normal Blender hangs in these conditions.

Kubuntu Linux 64bits, 8GB Ram, nVidia GT 430 1GB, intel i7 3770

Please, I will be grateful if you do the test and tell me if you are having the same problem.

I tried exactly what you said, and my computer was lagging severely just to increase the “Octree Depth.”

I think the problem is that no computer is meant to handle 1,275,128 verts, so it would probably take a high power machine about a month to complete the “Limited Dissolve” calculation, and that’s assuming it doesn’t kill the computer.

Hope this helps. :slight_smile:

@MtndewMan98, thanks for taking your time to do this test.
It is true that there are a lot of vertices. The weird thing is that the PC resources are not depleted. There is still free a lot of video memory, lots of RAM and CPU is not being used extensively. Also you may notice that while Blender hangs, you can continue working on the PC without problems. Without knowing much about it, I think if Blender is trying to calculate all these vertices then Blender should be using all the PC resources.
I have noticed that if you use wireframe view in viewport, Blender hangs a little less.
I think it’s a performance problem in Viewport and as I’ve read from other users developers are already working to improve that.

I am guessing these are single threaded operations not multithreaded… which means more then likely only one of your 4 cores (and only one of the 8 threads) that your cpu is actually being used. have a look at the task manager, if its using 13% or there abouts on one application, it means its maxing out one core.

some operations in blender are single threaded, some are multithreaded.

You may ask, Hey Doublebishop, why dont they make everything multithreaded… well, in reality not everything can be multithreaded… say you are counting 100 coins… you could split this amoung ten people fine, but then you still need one person at the end to pull it all together. This is just one example, but when you start dealing with millions of verticies / many objects… multithreading becomes VERY VERY complex.

It’s got nothing to do with the viewport, you’re asking the computer to iterate over millions of vertices, calculate its local space and for each one calculate if it is planar with two adjoining vertices, and if so then search every connecting vertex to any of THOSE vertices and search to see if THOSE are planar as well. Rinse and repeat ad nauseaum. Then, even if it does find planar verts, it has to then calculate how to turn those into ngons. After that it can finally update the mesh data, and finally update the viewport. There is no 3D package in existence that could do this quickly.

@doublebishop, m9105826, Thanks for your answers.

I do not expect it to being quickly, I expect to see that at least Blender is working and using the resources of the PC. But Blender is completely hung, does not seem to be working. Anyway I had mentioned about the viewport performance for what I had been reading, like this:

I thought it could be related to what some users say.

Regarding other 3D programs I have no idea about it and I did not know that same thing happens in these conditions.

I correct myself what I said, although Blender seems to be hung and I can not enable Blender window, the system monitor shows me that Blender apparently is working, but with a single thread as doublebishop has said.