remove groups

For animation I make groups high and low res and then link them in my scene.
I have made to many groups for one character.

How can I delete groups they keep showing when click in the object duplication - Group even after I have deleted all groups.

Click on the cube icon in the properties panel. there is a section listing all the groups. Also you can find them in the overview, I believe, if you twirl down the handles.

yes I know but I cannot delete them even when holding shift press X to remove from the group panel you can still select them again.
I do not want users to select groups by linking which I do not use anymore so I want to delete some groups definitely.
But that seems very hard .

I wish I could be more help, but I think what your doing is over my head a bit. I use groups in a more basic fashion than what you’re describing.

Ok no problem just want to delete groups completely so you cannot choose them anymore.

Groups should behave like other data blocks: once they have no users (or members in this case), if you save and reload the file, it should disappear. You may need to save and reopen a second time, but it works fine for me.

K. Horseman beat me to it…

Yeah what I just saw while testing is I had to save/reopen a couple times before all deleted groups disappeared. I’ve seen discussion about this issue happening in other areas of Blender too I think. I don’t remember why it is so.


Strange When I delete the groups save and reopen the blend file then left click on Add to Group I still can select old/deleted groups.
I even have deleted the scenes who used the character (linked). Blender 2.69

After you delete the groups, save and reopen, try immediately saving and reopening a second time and see what happens.

This info may be getting saved in the UI info. I doubt it, but try to open the .blend file while in blender and uncheck the box labeled load UI. See if that doesn’t do anything.

Did some test made two groups cubes and spheres no linking
deleted the groups- object icon groups
also removed groups from objects shift+ctr +alt+G
saved more then once and reopened more ten once but I still have the option to choose deleted groups ???

Solved I added the groups
Go to the outliner screen “groups” and then right click the groupname choose unlink groups.
Then save and reopen and the groupnames are gone.

Maybe there’s other objects still in the groups you are trying to delete. Check the Outliner with display mode set to Groups to see all objects assigned to the groups in question.

That’s my next routine advice in spite of test you just mentioned. To be clear, you are saving then reopening, saving again then reopening?

That’s all I’ve got. Hope it helps.


Ah, cross-posted on ya.

Hmmm. I wonder if a bug or just another Blender quirk. On the other hand, save/reopen twice worked for me after deleting groups in Object Panel.

Blender 2.69 Official x64 Windows7.

Have a good day.


yes that’s the solution I found also thanks.