Removing double edges

Blender has this very useful Remove doubles for vertices, but often, when importing models created with Wings3D, I end up with models containing overlapping edges. This creates problems with subsurfs. After removing doubles, recalculating normals, etc, subsurfed models still have these odd areas in them. I discovered that the culprit seems to be additional edges hidden under colinear vertices. Something like this:
x-----x-----x

An extra edge is present which connects the end vertices, but is hidden from view because it is underneath.

Is there any way of detecting and removing these extra edges?
Iā€™m doing this by temporarily moving vertices to see if any hidden edges are present, but there has to be an easier way.

You could try the Select Non-Manifold option in the Select menu (in the 3D view header in edit mode).

This should select all the vertices with overlapping edges.

Martin

2 Likes

Thanks! That worked.