Removing Fillet(s) from imported (stl) file

I often have the problem, that imported CAD-models have fillets and chamfers all over the place.
This here is a Duplo Track from here: https://www.thingiverse.com/thing:2758783

Then I found an easy solution!

  1. Change pivot point to 3D Cursor

  2. Go to Edit mode [TAB]

  3. Select the vertex at the end of the radius (fillet)

  4. Press [SHIFT]+[S] then “Cursor to Selected”

  5. Select all the vertices from this fillet
    image

  6. Press [S], [SHIFT]+[Z], [0]. In my case, that is! What it does: It scales all the vertices in XY to 0. All the vertices are now on the Z-axis. If your fillet is on an other axis, just scale to that.
    image

  7. Let’s repeat that an another fillet (and for each you want to remove):
    a) image
    b) image
    c) image
    d) image

  8. (Optional) leave edit mode and apply a “Decimate” modifier to reduce the unneeded faces, edges and vertices (in my case I used the “Planar” option).

  9. Use the “3D-Printing” add-on to make sure it’s all tight and clean to print.