Render Button & Camera Manager For Blender 2.81 [UPDATE 07/01/2020] - v0.3.7

Oh wait, I’ve just read that Blender 2.81 has no support for now. I tried it on 2.8 and it’s damn amazing! Thanks for this addon and sorry to bother you. What’s weird is that other plugins that do a similar multi-camera rendering thing also don’t work.
The “insert camera to view” button is dope

Do you think that you could add some buttons and a progress bar for animations?

Also, other timeline/playback/options buttons would be welcome:
https://docs.blender.org/manual/en/latest/render/output/animation_player.html

When will you be releasing the 2.81 addon mate?

2 Likes

v 2.81
v 2.82
Addon work but.
If you choose animation render with selector in addon tab. I mean switch to animation from addon and tap “Render Animation” from addon - the render does not end and goes round and round again and again.
But… if use for render animation button from internal blender option from upper menu - work nice.

Great addon, been using it since the beginning! Any news on an update for 2.81 or possibly support for 2.82?

1 Like

@all Sorry for silence! Now busy times are gone !

yes it’s on the track, stay tuned

Happy Blending !

8 Likes

Can’t wait, I love this add-on!

[UPDATE 05/12/2019] : Render Button & Camera manager for Blender 2.81 - v0.3.6

WHAT’S NEW:

After a few small changes and a long wait… Full compatibylity with Blender 2.81 !
Nothing more for now ( isn’t too bad ! )

Disclamer

During tests, I encountered some unexpected and undocumented crash during batch rendering, only with some files (exactly 5 out of 40).

I still dont know why, but for each of these files, the problem has been solved by saving the file with v2.81 and reopening it before rendering.

Maybe these files has been created with one of the 2.80 beta . I dont know

so if you have a similar problem with one of your files think about it …

Outdated

Download link:
render_button.py (183.2 KB) - v0.3.6 -[UPDATE 05/12/2019]

Happy Blending !

9 Likes

My wait has been rewarded :smiley:
Thanks for sharing this!

Edit: hm, yes, it crashed here as well. I tried rendering an animation, I noticed an warning popped up but I didn’t have the time to copy the info. I’ll try again.
For the record, I was trying on a new scene created in 2.81.

Patience is always rewarded :wink:

Finally!! :heart_eyes: :heart_eyes: :heart_eyes:
Tnx a lot for your time and work!

@Andrew_Ray:

I don’t have error with animation rendering here. But it’s a crash during render or an error when you start rendering ?

The problems encountered during the tests are crash, not just error. Blender simply disappears during rendering (batch rendering only) without any type of error message.

@Magogg: Thx :slightly_smiling_face:

1 Like

Sorry for the late reply

It’s a crash during render and it seems it’s pretty consistent so far. I’ll do more testing.

Now this is really the essential addon for my work with multiple cameras, each different aspect and resolution. Coming from maya, i was flabbergasted by the lack of fundamental batch parameters.
Your camera manager emerged just in time and meanwhile delivers everything i need.
And yes, i think it should be part of the distribution.
Thank you very much for your work!

Carlito
(Still looking for a decent loft tool)

1 Like

I get a following error when trying to activate (v. 0.3.6):

Traceback (most recent call last):
  File "C:\programs\b281a\2.81\scripts\modules\addon_utils.py", line 351, in enable
    mod = __import__(module_name)
ModuleNotFoundError: No module named 'render_button_0'

hi all !

@burnin :

Sorry for the trouble.

Okay. Can you tell me more about the context. I can’t help you without more information.

I can’t reproduce this error here.

Can you be more specific when you say “when trying to activate” . Do you mean the first time just after addon installed?

other addons installed ? …

@Andrew_Ray : ok i stay tuned

@Magogg: thx :slightly_smiling_face:

Happy Blending !

NP, thanks for your work!
Yes, the first time after installation. And yes, I have quite a few other addons installed — W10, Blender 2.81a.

Tested on a clean slate (a’la Standalone) and it installs fine.
Am looking into the problem - will get back with findings :wink:

hi burnin
Thx for reply, feedback always needed and appreciable :slightly_smiling_face:

Shuffled all around, but haven’t found a culprit :upside_down_face: … it’s working now
// will notify, if it happens again

Ok glad to hear that, thanks for reply :slightly_smiling_face: and…

Happy Blending !