Render Button & Camera Manager For Blender 3+ [QUICK FIX 07/04/2022] - v0.3.9

hi all !

@burnin :

Sorry for the trouble.

Okay. Can you tell me more about the context. I can’t help you without more information.

I can’t reproduce this error here.

Can you be more specific when you say “when trying to activate” . Do you mean the first time just after addon installed?

other addons installed ? …

@Andrew_Ray : ok i stay tuned

@Magogg: thx :slightly_smiling_face:

Happy Blending !

NP, thanks for your work!
Yes, the first time after installation. And yes, I have quite a few other addons installed — W10, Blender 2.81a.

Tested on a clean slate (a’la Standalone) and it installs fine.
Am looking into the problem - will get back with findings :wink:

hi burnin
Thx for reply, feedback always needed and appreciable :slightly_smiling_face:

Shuffled all around, but haven’t found a culprit :upside_down_face: … it’s working now
// will notify, if it happens again

Ok glad to hear that, thanks for reply :slightly_smiling_face: and…

Happy Blending !

Hi man. I’m getting an error when I try to use your addon on stable 2.81. I also got it while the addon didn’t support 2.81 yet. It would be nice if you could tell me how to fix it so I can work with multiple cameras. THX!!!
Edit: I REALLY appreciate this addon. It lets us work with a very fast workflow for multi shot renders/animations. So thanks for the work!

Hi Miquel_Rosell

yes I am aware about this error ! :confused:

It is solved in the v0.3.7 the next update for this week.

This is because output render format is set on an animation format (avi, ffmpeg…) and not an image format (jpeg, png …) and your render is a still render…


It s a problem only when autosave is active.

To avoid this error, in the next realease, i implemanted a test to set automatically the right render file format accordingly to the render type (image or animation).

so for now, with autosave active, just make sure the file format match the rendering type


Ooooohhhhhhhhh I see. Okay, I’ll try changing the format. Thanks!!!
I thought about this when I read the error, but I wasn’t really sure :wink:

Looks like a great add-on, but does it let you render all your cameras animations independently even when not put after each other in the timeline? Let me explain, I would like to batchrender all different cameras in a scene over the same first 250 frames of the timeline. Same animation scene different angles, is this possible with this add-on?

hi dbalex.

Sorry for the late reply.

Yes I see. Sorry not yet. I know this rendering option is expected, in first place by me :slightly_smiling_face:, it’s in my todo list from the start…

1 Like

Just found this and it looks great! Thank you very much for sharing it! I just downloaded it so I didn’t really use it that much, but I was wondering if there is the ability to add the name of the camera somewhere in the file name output. It would be something really useful, at least for my workflow!

Thank you!

hi Bernardo

That’s how it is by default with autosave . Render files are named with the name of the camera !

1 Like

Thanks, that sounds great!

After seeing this video :
That made me think that it would be logical for your addon to feature an option to make cameras “trembling”.

The Object Shake addon could help you integrate this option into RB&CM:

[UPDATE 07/01/2020] : Render Button & Camera manager for Blender 2.81 - v0.3.7

Ok ! After a lonnnnnng week :slight_smile:


Two bug fixing for this first new year release

Bug fixed:

In the previous version (v036) In selection menu, if you choose “invert” when all the cameras are selected you get an “IndexError” error.

Bug fixed:

related to this post

In the previous version (v036) If you render an image with autosave and output format set to a video format ( AVI, FFMPEG …) you get a “RuntimeError”

Download link: (170.0 KB) - v0.3.7 -[UPDATE 07/01/2020]

All the best for new year !

Happy Blending !


Hi Hokuss,
I installed you add on but when I tried to activate it, I received an error…:

May you help me, please?

Great addon! Thanks for sharing mate! :heart_eyes:

Hi Hokuss,
there is a way to receive an answer about this problem (

Hi Duca


Can you be more precise when reporting an error please.

  • blender version
  • clean install, if not, have you installed other addons…
  • have you tested with a clean install
  • have you tested with your current setup but with all other addons desactivated…

I can’t help you without informations.

I can’t reproduce this error here. But it is very similar what burnin reported.

It’s look likes he solved this problem. Perhaps can you see with him how.

This error seems uncommon. I think is related to specific setup, other addons, particular version of blender… I don’t know yet

In your specific case, tell me if i’m wrong, but you don’t use the official blender version?

I don’t use E-Cycles.

Hi Hokuss,
I just tried with stable 2.81a, same error.
I have some other add ons:
I don know what you mean with “clean install”…: I simply installed it going to Edit/preferences/Add Ons/Install… loading you render_button_0.3.7.
But again, when I try to activate it I receive the same error.
I desactivated all other add ons, no way.
I don’t use E-Cycles.
I hope you can find a solution…