Render Doing Wrong Frames

So when I render something such as frame 500, it just skips ahead and starts rendering frame 999. Am I doing something wrong?

This is a link to DL all the files that it uses and the .blend!xgZFWALK!AC5TBwmiLgSdT00nfPktHosiOPgzU12XY-fYesK9RTA

It is trying to do a “Sequence Render” as opposed to a normal render. If you move out of the VSE and disable ‘Sequencer’ in the Properties/render tab, then it works.
You may have notices that the offset is constant, so I am sure there is something going on that I have missed.

Yep, that was the problem, thanks for that