Render error

Hello friends, have a good weekend everyone.
I can’t render the scene I’m working on. After pressing F12 and opening the rendering screen, I was getting an out of memory error at the top left on the black screen. I used 4K textures, 12 of them each have base color, normal map, displacement and roughness. The total size of each texture varies between 40-70 mb. I tried the following with the information I searched on the forums.

  • Cycles supported, experimental, cpu, gpu compute
  • Eevee
  • Performance tab → reduce the number of tiles
  • Adaptive sampling
  • The Blender program was installed in C disk and C was about to fill up. I installed it on the SSD with 110 GB of free space and it still didn’t work.

As it can be seen at the bottom right, Memory: I think it should use 5.4 GB.

My graphics card: RTX 2060
Processor: Intel i7-10750H

Thank you in advance

Hello and welcome

Sounds a bit like a too high render resolution or could be too much geometry…or the both
What dimensions are you trying to render and how many triangles does your scene have ?

Seems odd if it fails with the same error when you set it to CPU rendering only.

dimensions: 1920x1080 px
tris: 18,677,277

How much Ram do you have ?
You probably dont have enough memory to render. 18 mil tris is alot. i tested to render 18 mil tris and got about 5 gb memory use and i just subdivided a simple mesh, no textures. So plus your textures at atleast 40 mb times 12 would be 480 mb and the geo with around 5 gb you would need roughly 6 to 7 gb to render your scene…at minimum. Your operating system needs ram too so if you have just 8gb ram that wouldnt be enough. And for your graphicscard the 2060 has 6gb ram so thats for sure not enough.
when you click render at the left upper corner, blender does calculate the needed memory. What does it say until it reaches memory error?

Lower the resolution of your textures. You can also try Simplfy in the rendering pane.

Hello Im glad you asked about triangle count. I checked some of my models and they had like 4,000,000 triangles beacuse of subdivision surface modifier. I delete the modifiers then decreased the triangle count from 18,000,000 to 450,654 so I can render now. I think using the 4k textures does not affect this error.
Thank you so much