Render (F12) Issue

Hello all!

First at all, sorry for my english. It’s sometimes rebell.

I need a little help about Render. Noob attitude :slight_smile:

So when i render my view (Viewport Shading : Rendered, and not solid), i have a “good” render.
But when i use a render image (F12), i have only my background and one object.

For all modifier, camera and view are on.

With Rendered (Viewport S.)

With F12

Thanks for your help


Viewport render shows everything that is seen in viewport (not always, but when default viewport render is used).
Render (F12) renders everything that is set to be rendered and sometimes those things are not the same. Some objects may be visible, but excluded from render.

If we don’t see your file it’s hard to determine why some of your objects don’t render.

You may have:

  1. In Render Layers settings: excluded some layers from render. They are visible (so do render in viewport rendering), but excluded from render.

  2. Some objects are excluded from render because in outliner you deactivated them (a little camera checkbox).

When you know what to look for - it’s easy to determine the problem. Without seeing your file - I’m guessing.

hello Bartek.

It was the first proposition.

Thanks a lot! I learn a new thing :slight_smile:



Also guessing here

If you’re using duplication on the dupliobject/instanced object itself, it won’t render

Plane has face duplication on so that every face gets a cube placed on it. But if the cube has duplication set to anything other than “none”, it won’t render.

Time’s passing bye in your virtual World… Land gets flattened, someone has even settled back there…All while you press that F12.
Kidding, sorry…
Zero on numpad toggles between free view and view trough camera. You can see different things if camera is turned other way. Btw any Scene object can act as a Camera; select yours and menu View, Camera, Set Active Object as Camera (Ctrl-nmpd-0).

If that’s not the reason, you have something advanced going on. Connected to different server? Kidding again, sorry.

Edit: Wait… The clouds on the background are the same… Have something in Compositor? Any Renderlayers off?

Edit2: What else could we offer besides guessing game?


Lol Eppo. “My” virtual changed a lot, in better. And soon, we will have a new generation of it.

But, i come back in Blender, the render is better :yes:

The issue was find by BartekSkorupa. I had to work a little with the layers setting. Now, it’s fine.

But thanks JA12, for one of your suggestion. It can be useful for a next time.
And thanks Eppo, to make me laugh :slight_smile:



If you click different Renderlayers it will immediately start to render those layers when Viewport shading is set to Rendered.